Bug 1034732 - xmvn should fail if there is no "suitable repository" for given file extension
Summary: xmvn should fail if there is no "suitable repository" for given file extension
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xmvn
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-26 12:16 UTC by Michal Srb
Modified: 2013-12-09 14:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-09 14:15:37 UTC
Type: Bug


Attachments (Terms of Use)
build.log (2.62 MB, text/x-log)
2013-11-26 12:18 UTC, Michal Srb
no flags Details

Description Michal Srb 2013-11-26 12:16:58 UTC
Description of problem:

Currently XMvn skips artifact installation if there is no "suitable repository" found for given file extension. This may lead to situation where one can explicitly mark the artifact for installation:

%mvn_package org.jenkins-ci.plugins:mailer:hpi:: __default

But artifact doesn't get installed. XMvn silently skips the rule and build is successful.

build.xml contains following line:
[WARNING] Skipping installation of artifact org.jenkins-ci.plugins:mailer:hpi:1.5: No suitable repository found to store the artifact in.


Version-Release number of selected component (if applicable):
xmvn-1.3.0-4.fc21
javapackages-tools-3.4.1-2

Comment 1 Michal Srb 2013-11-26 12:18:33 UTC
Created attachment 829239 [details]
build.log

Comment 2 Mikolaj Izdebski 2013-12-02 09:43:03 UTC
(In reply to Michal Srb from comment #0)
> Currently XMvn skips artifact installation if there is no "suitable
> repository" found for given file extension.

That's correct.

> This may lead to situation where
> one can explicitly mark the artifact for installation:
> 
> %mvn_package org.jenkins-ci.plugins:mailer:hpi:: __default
> 
> But artifact doesn't get installed. XMvn silently skips the rule and build
> is successful.

Correct.  That is expected behavior.  Why do you think that's a bug?

Comment 3 Michal Srb 2013-12-02 10:02:27 UTC
I am not saying it's a bug. I filed this bug, because described behavior is kinda confusing. So maybe we could improve it a bit somehow, if possible.

Btw. why is it expected behaviour? I would personally expect failed build.

Comment 4 Mikolaj Izdebski 2013-12-02 10:16:32 UTC
(In reply to Michal Srb from comment #3)
> I am not saying it's a bug. I filed this bug, because described behavior is
> kinda confusing. So maybe we could improve it a bit somehow, if possible.

I have no idea how this could reasonably be improved.  Any suggestions?

> Btw. why is it expected behaviour? I would personally expect failed build.

Many projects build non-standard artifacts which are not mentioned in Fedora packaging guidelines and therefore not configured in javapackages-tools.  XMvn does not know where and how to install them.  Failing the build in case unknown artifact was found in the reactor is IMO unacceptable and would cause build failures of large number of packages.

If the artifact you are trying to install is a standard artifact type (commonly appearing) then the solution to your problem seems to be discussing with Fedora Java SIG how the artifact type should be installed, adding it to packaging guildeliness and then to javapackages-tools config.  This way XMvn will automatically handle this artifact type not only for this package, but for all other packages too.

If you are trying to install non-standard (uncommon) artifact then you have a choice of doing that manually or instructing XMVn how to do that by adding appropriate configuration in your package.

Comment 5 Mikolaj Izdebski 2013-12-09 14:15:37 UTC
As explained in previous comments current behavior is correct.  Closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.