Bug 1034790 - Unable to start mariadb.
Summary: Unable to start mariadb.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedFreezeException
: 1035951 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-26 14:07 UTC by Matthew Javelet
Modified: 2013-12-14 04:04 UTC (History)
13 users (show)

Fixed In Version: mariadb-5.5.34-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-14 03:38:12 UTC


Attachments (Terms of Use)
Dumps of systemctl mariadb.service status and journalctl -xn (2.71 KB, text/plain)
2013-11-26 14:08 UTC, Matthew Javelet
no flags Details
mariadb.log (8.69 KB, text/x-log)
2013-11-26 14:52 UTC, Matthew Javelet
no flags Details

Description Matthew Javelet 2013-11-26 14:07:55 UTC
Description of problem:
In the current build of F20 x64 running Gnome I'm currently unable to start mariadb.

I receive the following error:
[matthew@lilith ~]$ sudo service mariadb start
Redirecting to /bin/systemctl start  mariadb.service
Job for mariadb.service failed. See 'systemctl status mariadb.service' and 'journalctl -xn' for details.

Happened on fresh installations of Fedora 20 Beta-TC6 and TC2.

Version-Release number of selected component (if applicable):
mariadb-5.5.34

How reproducible:
100%

Steps to Reproduce:
1. start mysqld/mariadb

Actual results:
mariadb fails to start

Expected results:
mariadb starts

Additional info:
See attachment for systemctl status and journalctl -xn dumps

Comment 1 Matthew Javelet 2013-11-26 14:08:58 UTC
Created attachment 829283 [details]
Dumps of systemctl mariadb.service status and journalctl -xn

Comment 2 Honza Horak 2013-11-26 14:35:44 UTC
It seems like your server refuses to start. What is in your log file /var/log/mysqld.log (resp. /var/log/mariadb/mariadb.log)?

Comment 3 Matthew Javelet 2013-11-26 14:52:26 UTC
Created attachment 829311 [details]
mariadb.log

Comment 4 Matthew Javelet 2013-11-26 14:55:21 UTC
Log added.

I have gained access to the shell via:
sudo mysqld -u root -p

I'm able to start/configure mysql with
sudo mysqld_safe 
sudo mysql_secure_installation

The login information i provided to gain shell access with the first listed command was with the information provided to the configuration command.

I then tried to access phpmyadmin with the newly created/tested credentials and it threw this error:
#2002 - Permission denied
The server is not responding (or the local server's socket is not correctly configured).

Comment 5 Matthew Javelet 2013-11-26 15:06:24 UTC
Scratch that last part about not gaining access to phpyadmin.

I rebooted, and turned on mariadb with mysqld_safe and was able to login to phpmyadmin with the credentials i provided in mysql_secure_installation.

Comment 6 Guillaume Kulakowski 2013-11-26 19:58:55 UTC
Same issue for me.

Comment 7 Alexey Torkhov 2013-11-27 08:00:12 UTC
Same issue here. With previous version of mariadb-server it works fine.

Comment 8 Honza Horak 2013-11-27 14:58:10 UTC
Found the issue, new build is on the way:
http://koji.fedoraproject.org/koji/buildinfo?buildID=481161

Comment 9 Fedora Update System 2013-11-27 19:01:50 UTC
mariadb-5.5.34-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mariadb-5.5.34-2.fc20

Comment 10 Andre Klapper 2013-11-27 21:09:00 UTC
Confirming that updating to mariadb-5.5.34-2.fc20 fixed the problem for me.

Comment 11 Matthew Javelet 2013-11-27 21:13:56 UTC
I can verify that it now works with the latest update.

Comment 12 Fedora Blocker Bugs Application 2013-11-27 21:47:58 UTC
Proposed as a Freeze Exception for 20-final by Fedora user tflink using the blocker tracking app because:

 All system services present after installation with one of the  release-blocking package sets much start properly, unless they require hardware which is not present.

This package is shipped on at least the KDE live media ... even though it's not started/used by default from the normal server unit

Comment 13 Honza Horak 2013-11-28 08:19:12 UTC
I may miss something, but mariadb-5.5.34-1 has never been in stable, since this bug was found while it was in updates-testing repository. Thus, I'd say Freeze Exception is not necessary, because previous version (still in stable) mariadb-5.5.33a-2.fc20 should be working just fine.

Comment 14 Adam Williamson 2013-11-28 21:53:53 UTC
Yep, as per honza. The broken one never went stable. You may have got it on a netinstall, tflink. -1

Comment 15 Honza Horak 2013-11-29 08:08:49 UTC
*** Bug 1035951 has been marked as a duplicate of this bug. ***

Comment 16 Kashyap Chamarthy 2013-11-29 08:19:51 UTC
Hmm, I was using updates-testing, and hit this as a consequence of updating to mariadb-5.5.34-1.fc20.x86_64 on my OpenStack setup.

Only to find (after an hour) that downgrading it to mariadb-5.5.33a-2.fc20.x86_64 worked.

Thanks for the fix.

Comment 17 Adam Williamson 2013-12-02 18:55:01 UTC
kashyap: updates-testing is enabled by default for pre-releases so lots of people run into it; the discussion about FE status doesn't mean the bug isn't valid or serious, it's just specifically about whether we need to pull the build through freeze into the Final images or not.

Comment 18 Adam Williamson 2013-12-02 18:56:22 UTC
Discussed at 2013-12-02 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-12-02/f20-blocker-review-%234.2013-12-02-17.02.log.txt . Rejected as a freeze exception issue: the broken build never made it to stable, so there is no need to break freeze here. The build currently in stable - and hence which will be on the F20 media - is not affected by this issue. No-one who installs F20 after today will see the bug on updates, either, as the broken update has already been superseded by the working one.

Comment 19 Fedora Update System 2013-12-14 03:38:12 UTC
mariadb-5.5.34-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.