Bug 1034805 - [PATCH] Do not pass $ to repo id in mockchain
Summary: [PATCH] Do not pass $ to repo id in mockchain
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Clark Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1096440 1096524 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-26 14:30 UTC by Miroslav Suchý
Modified: 2014-10-10 16:04 UTC (History)
4 users (show)

Fixed In Version: mock-1.1.41-3.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-01 22:22:44 UTC


Attachments (Terms of Use)
Patch fixing this problem (1.28 KB, patch)
2013-11-26 14:48 UTC, Miroslav Suchý
no flags Details | Diff
Patch fixing previous patch (895 bytes, patch)
2014-03-12 10:19 UTC, Miroslav Suchý
no flags Details | Diff

Description Miroslav Suchý 2013-11-26 14:30:25 UTC
Description of problem:
If you run:
 mockchain -a 'http://foo/$basearch'
it will then construct yum repo with id foo_$basearch and yum take dolar sign as invalid character in repoid.

Version-Release number of selected component (if applicable):
mock-1.1.35-1.fc20.noarch

How reproducible:
deterministic

Steps to Reproduce:
1. /usr/bin/mockchain -r fedora-20-i386 -l /var/tmp/mockremote-1sBD1/build/ -a 'http://download.fedoraproject.org/pub/fedora/linux/updates/testing/$releasever/$basearch/' -a http://copr-be.cloud.fedoraproject.org/results/churchyard/slic3r//fedora-20-i386 http://churchyard.fedorapeople.org/SRPMS/slic3r-1.0.0-0.2.RC1.fc21.src.rpm

Actual results:
DEBUG util.py:331:  Executing command: ['/usr/bin/yum-builddep', '--installroot', '/var/lib/mock/fedora-20-i386-msuchy-15763/root/', '/var/lib/mock/fedora-20-i386-msuchy-15763/root///builddir/build/SRPMS/slic3r-1.0.0-0.2.RC1.fc20.src.rpm'] with env {'LANG': 'en_US.UTF-8', 'TERM': 'vt100', 'SHELL': '/bin/bash', 'CCACHE_DIR': '/tmp/ccache', 'HOSTNAME': 'mock', 'PROMPT_COMMAND': 'echo -n "<mock-chroot>"', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'HOME': '/builddir', 'CCACHE_UMASK': '002'}
DEBUG util.py:281:  Bad id for repo: download.fedoraproject.org_pub_fedora_linux_updates_testing_$releasever_$basearch_, byte = $ 60


Expected results:
no errors

Additional info:
I will provide you with patch within 48 hours.

Comment 1 Miroslav Suchý 2013-11-26 14:48:14 UTC
Created attachment 829310 [details]
Patch fixing this problem

Comment 2 Clark Williams 2014-01-04 20:50:27 UTC
Applied for the 1.1.36 build.

Comment 3 Fedora Update System 2014-02-06 02:09:02 UTC
mock-1.1.36-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.36-1.fc19

Comment 4 Fedora Update System 2014-02-06 02:10:43 UTC
mock-1.1.36-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.36-1.fc20

Comment 5 Fedora Update System 2014-02-06 02:12:14 UTC
mock-1.1.36-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.36-1.el6

Comment 6 Fedora Update System 2014-02-06 21:08:11 UTC
Package mock-1.1.36-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.1.36-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0467/mock-1.1.36-1.el6
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-02-08 05:02:32 UTC
mock-1.1.36-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Miroslav Suchý 2014-03-12 10:19:35 UTC
Created attachment 873423 [details]
Patch fixing previous patch

The original patch was incorrectly applied and you accidentally removed one line.
It should be taken back.

Comment 9 Fedora Update System 2014-03-25 20:24:52 UTC
mock-1.1.37-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.37-1.fc19

Comment 10 Fedora Update System 2014-03-25 20:27:20 UTC
mock-1.1.37-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.37-1.fc20

Comment 11 Fedora Update System 2014-03-25 20:29:23 UTC
mock-1.1.37-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.37-1.el6

Comment 12 Miroslav Suchý 2014-03-26 08:13:54 UTC
Comment #8 still has not been addressed.

Comment 13 Fedora Update System 2014-03-26 17:38:07 UTC
Package mock-1.1.37-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.1.37-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0960/mock-1.1.37-1.el6
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2014-03-27 17:47:55 UTC
mock-1.1.37-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.37-2.fc20

Comment 15 Fedora Update System 2014-03-27 17:49:53 UTC
mock-1.1.37-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.37-2.fc19

Comment 16 Fedora Update System 2014-03-27 17:51:41 UTC
mock-1.1.37-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.37-2.el6

Comment 17 Fedora Update System 2014-03-29 19:17:20 UTC
Package mock-1.1.37-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.1.37-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0999/mock-1.1.37-2.el6
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2014-03-31 19:04:31 UTC
mock-1.1.38-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.38-1.fc19

Comment 19 Fedora Update System 2014-03-31 19:06:55 UTC
mock-1.1.38-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.38-1.el6

Comment 20 Fedora Update System 2014-03-31 19:08:48 UTC
mock-1.1.38-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.38-1.fc20

Comment 21 Fedora Update System 2014-04-01 19:20:26 UTC
Package mock-1.1.38-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.1.38-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1031/mock-1.1.38-1.el6
then log in and leave karma (feedback).

Comment 22 Fedora Update System 2014-04-09 13:18:49 UTC
mock-1.1.38-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2014-04-18 15:37:44 UTC
mock-1.1.38-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2014-04-19 09:20:03 UTC
mock-1.1.38-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Miroslav Suchý 2014-05-12 07:57:14 UTC
Reopening per #8.

Comment 26 Miroslav Suchý 2014-05-12 07:58:00 UTC
*** Bug 1096440 has been marked as a duplicate of this bug. ***

Comment 27 Miroslav Suchý 2014-05-12 07:59:30 UTC
*** Bug 1096524 has been marked as a duplicate of this bug. ***

Comment 28 Miroslav Suchý 2014-05-16 07:43:58 UTC
Fixed in commit 8e0c77d081e33a682b6aebbb64c475a6029e5b28

Comment 29 Fedora Update System 2014-05-27 15:39:27 UTC
mock-1.1.39-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.39-1.fc19

Comment 30 Fedora Update System 2014-05-27 15:39:44 UTC
mock-1.1.39-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.39-1.el6

Comment 31 Fedora Update System 2014-05-27 15:40:00 UTC
mock-1.1.39-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.39-1.fc20

Comment 32 Fedora Update System 2014-05-27 19:11:56 UTC
Package mock-1.1.39-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.1.39-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1506/mock-1.1.39-1.el6
then log in and leave karma (feedback).

Comment 33 Fedora Update System 2014-06-01 22:22:44 UTC
mock-1.1.39-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 34 Fedora Update System 2014-06-25 20:00:02 UTC
mock-1.1.39-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 35 Fedora Update System 2014-07-18 02:13:25 UTC
mock-1.1.40-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.fc20

Comment 36 Fedora Update System 2014-07-18 02:13:51 UTC
mock-1.1.40-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.fc19

Comment 37 Fedora Update System 2014-07-18 02:14:13 UTC
mock-1.1.40-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.el6

Comment 38 Fedora Update System 2014-07-18 17:45:32 UTC
mock-1.1.41-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.fc20

Comment 39 Fedora Update System 2014-07-18 17:45:58 UTC
mock-1.1.41-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.fc19

Comment 40 Fedora Update System 2014-07-18 17:46:24 UTC
mock-1.1.41-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.el6

Comment 41 Fedora Update System 2014-07-20 03:24:42 UTC
mock-1.1.41-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 42 Fedora Update System 2014-07-22 18:08:01 UTC
mock-1.1.41-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 43 Fedora Update System 2014-09-16 16:47:00 UTC
mock-1.1.41-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-2.fc19

Comment 44 Fedora Update System 2014-09-30 09:00:15 UTC
mock-1.1.41-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-3.fc19

Comment 45 Fedora Update System 2014-10-10 16:04:25 UTC
mock-1.1.41-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.