Bug 103481 - Floating point exception when building CVS kdelibs
Summary: Floating point exception when building CVS kdelibs
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.3
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-01 02:04 UTC by David Favis-Mortlock
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 14:37:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Favis-Mortlock 2003-09-01 02:04:50 UTC
Description of problem:

When building kdelibs from CVS, I get the following:

khtmlview.cpp: In method `khtml::EditableCharacterIterator
&khtml::EditableCharacterIterator::operator++ ()':
khtmlview.cpp:2408: Internal error: Floating point exception.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

Tne command that produced this is:

make[3]: Entering directory `/usr/src/kde/kdelibs/khtml'
source='khtmlview.cpp' object='khtmlview.lo' libtool=yes \
depfile='.deps/khtmlview.Plo' tmpdepfile='.deps/khtmlview.TPlo' \
depmode=gcc3 /bin/sh ../admin/depcomp \
/bin/sh ../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -I. -I.
-I.. -I../dcop -I../kio/kssl -I../kjs -I../kimgio -I./java -I../dcop -I./misc
-I./dom -I./xml -I./html -I./css -I../libltdl -I../kio/kssl -I../kio/kssl
-I../kdeprint -I../interfaces -I../interfaces/kregexpeditor -I../kwallet/client
-I.. -I../dcop -I../libltdl -I../kdefx -I../kdecore -I../kdeui -I../kio
-I../kio/kio -I../kio/kfile -I.. -I/usr/lib/qt/include -I/usr/X11R6/include   
-DQT_THREAD_SUPPORT  -D_REENTRANT -I/usr/include/pcre  -Wnon-virtual-dtor
-Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wwrite-strings -ansi
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts
-O2 -fno-exceptions -fno-check-new -fno-common  -DQT_CLEAN_NAMESPACE
-DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -c -o
khtmlview.lo `test -f 'khtmlview.cpp' || echo './'`khtmlview.cpp

This is happening consistently on recent CVS downloads, at least for the past
week. I've reported the problem to bugs.kde.org, but have been told that it is a
RedHat gcc problem and they can do nothing about it.



Version-Release number of selected component (if applicable):

gcc-2.96-113


How reproducible:

consistent


Steps to Reproduce:
1. Build kdelibs from CVS source
2.
3.
    

Actual results:

See above.


Expected results:

A clean compile.



Additional info:

Comment 1 Jakub Jelinek 2004-10-07 14:37:27 UTC
kdelibs certainly have built since then.


Note You need to log in before you can comment on or make changes to this bug.