Bug 103490 - Network Device Control throws exception after installation of 2.6 kernel
Summary: Network Device Control throws exception after installation of 2.6 kernel
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-01 05:30 UTC by John Yau
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-24 10:37:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Yau 2003-09-01 05:30:52 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:

Upgrade to 2.6 kernel using
http://people.redhat.com/arjanv/2.5/RPMS.kernel/kernel-2.6.0-0.test4.1.32.i686.rpm

1. System Tools -> Network Device Control
2. Configure 
3. New Device
4. Select wireless device
5. Forward
    
Actual results:

Component: redhat-config-network
Version: 1.2.0
Summary: TB
/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NC_functions.py:119:rpms_notinstalled:TypeError:
rpmdb open failed
Traceback (most recent call last):
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py",
line 144, in on_start_page_next
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/WirelessInterface.py",
line 129, in get_druids
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/WirelessInterface.py",
line 58, in init_gui
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NC_functions.py",
line 144, in request_rpms
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NC_functions.py",
line 119, in rpms_notinstalled
TypeError: rpmdb open failed

Expected results:


Additional info:

Comment 1 Harald Hoyer 2003-09-01 08:11:58 UTC
seems like the rpm db could not be opened.. hmm..

Comment 2 John Yau 2003-09-01 15:14:50 UTC
actually yes...I haven't been able to use rpmdb or rpm from the shell until I 
added this

export LD_ASSUME_KERNEL=2.2.5

to the environment.  But redhat-config-network still exhibits the same 
behavior even after the addition.

This is where I found the info to add to the environment

http://thomer.com/linux/migrate-to-2.6.html


Comment 3 Harald Hoyer 2003-09-01 15:17:18 UTC
try this as root:
# LD_ASSUME_KERNEL=2.2.5 /usr/sbin/redhat-config-network

Comment 4 John Yau 2003-09-01 16:13:24 UTC
Okay... the rpmdb seems to be accessible now, but now I get complaints about


Error saving Configuration!
[Errno 2] No such file or directory:
'/etc/sysconfig/network-scripts//ifcfg-lo.rpmsave'

when I try to activate a device.

A similar error about not being able to find the same file shows up in
rc.sysinit sequence at boot.

Comment 5 Harald Hoyer 2003-09-02 09:29:10 UTC
update to 1.2.15 and the last error is gone..
http://rhn.redhat.com/errata/RHBA-2003-183.html



Note You need to log in before you can comment on or make changes to this bug.