Bug 1034919 - Docker-io needs libcgroup installed and running in order to function
Summary: Docker-io needs libcgroup installed and running in order to function
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: docker-io
Version: el6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Vincent Batts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1035319 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-26 17:34 UTC by Nux
Modified: 2013-12-14 02:46 UTC (History)
6 users (show)

Fixed In Version: docker-io-0.7.0-14.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-03 01:19:34 UTC


Attachments (Terms of Use)
Patch fot cgconfig boot (2.02 KB, patch)
2013-11-29 13:15 UTC, Marek Goldmann
no flags Details | Diff

Description Nux 2013-11-26 17:34:43 UTC
Description of problem:
"docker run" will error out when cgroups are not present:
"[error] commands.go:2459 Error resize: Error: bad file descriptor"


Version-Release number of selected component (if applicable):
0.7 0.20.rc7.el6

How reproducible:
always

Steps to Reproduce:
1. yum --enablerepo=epel-testing install docker-io
2. service docker start
3. docker run -i -t ubuntu /bin/bash

Actual results:
"[error] commands.go:2459 Error resize: Error: bad file descriptor"

Expected results:
BASH prompt in the container

Additional info:
Installing cgroups fixes the problem:
"yum -y install libcgroup && service cgconfig start"

Comment 1 Vincent Batts 2013-11-27 15:13:34 UTC
*** Bug 1035319 has been marked as a duplicate of this bug. ***

Comment 2 Vincent Batts 2013-11-27 17:04:10 UTC
The same is likely true for fedora, but libcgroup is already landed. I will add the Requires: not inside a conditional just for RHEL

Comment 3 Vincent Batts 2013-11-27 17:52:48 UTC
The new package is building in koji, and will be ready for validation shortly.
http://koji.fedoraproject.org/koji/taskinfo?taskID=6233070

Comment 4 Fedora Update System 2013-11-27 18:08:51 UTC
docker-io-0.7.0-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/docker-io-0.7.0-2.el6

Comment 5 Fedora Update System 2013-11-28 09:42:25 UTC
docker-io-0.7.0-9.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/docker-io-0.7.0-9.el6

Comment 6 Fedora Update System 2013-11-28 18:44:21 UTC
docker-io-0.7.0-10.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/docker-io-0.7.0-10.el6

Comment 7 Stephen Tweedie 2013-11-29 12:27:26 UTC
Reopening.

docker-io-0.7.0-10.el6 adds the dependency on libcgroup, but still doesn't ensure that cgconfig is actually started.  Starting docker with either service start docker or automatically via chkconfig docer on still results in a non-functioning docker service due to missing cgroups on my rhel6 install:

# service docker start
Starting docker:	                                   [  OK  ]
# docker run -n -i -t mattdm/fedora /bin/bash
[error] commands.go:2470 Error resize: Error: bad file descriptor
# cat /proc/mounts |grep cgroup
# 

and after chkconfig docker on and a reboot:

# service cgconfig status
Stopped
# service docker status
docker (pid  1477) is running...
# cat /proc/mounts |grep cgroup
#

Comment 8 Marek Goldmann 2013-11-29 12:58:15 UTC
For sure this should be added to the init.d file:

# Required-Start: $network cgconfig

This will make sure that cgconfig service will be started before docker. Other thing is the cgconfig service start. By default the service is not enabled on boot. I'm unsure what is the valid way to change this. One way is to add it in the %post section of the RPM. But this doesn't seem good to me.

Other option is to check the status of cgconfig in the docker init.d file and launch it if it's stopped. And I think this would be a preferred solution for this.

We can also add a warning that would say how to enable the service (chkconfig cgconfig on) when we detect that docker service is marked to start on boot and cgconfig is not.

Any other ideas / comments?

Comment 9 Marek Goldmann 2013-11-29 13:15:32 UTC
Created attachment 830646 [details]
Patch fot cgconfig boot

I'm attaching a patch to fix the cgconfig service boot requirement.

Please note that this patch should be applied against master AFTER applying patch from bug 1036027.

Comment 10 Fedora Update System 2013-12-01 02:50:02 UTC
docker-io-0.7.0-10.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 11 Fedora Update System 2013-12-01 19:33:05 UTC
docker-io-0.7.0-12.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/docker-io-0.7.0-12.fc20

Comment 12 Fedora Update System 2013-12-02 02:44:46 UTC
docker-io-0.7.0-12.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/docker-io-0.7.0-12.fc19

Comment 13 Fedora Update System 2013-12-02 04:58:45 UTC
docker-io-0.7.0-12.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/docker-io-0.7.0-12.el6

Comment 14 lnie 2013-12-02 06:14:53 UTC
tested with 0.7.0-10.fc20 and 0.7.0-12.both work fine

Comment 15 Fedora Update System 2013-12-02 15:59:10 UTC
docker-io-0.7.0-14.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/docker-io-0.7.0-14.fc20

Comment 16 Fedora Update System 2013-12-02 16:16:23 UTC
docker-io-0.7.0-14.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/docker-io-0.7.0-14.fc19

Comment 17 Fedora Update System 2013-12-02 16:27:32 UTC
docker-io-0.7.0-14.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/docker-io-0.7.0-14.el6

Comment 18 Fedora Update System 2013-12-03 01:19:34 UTC
docker-io-0.7.0-14.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2013-12-03 10:37:58 UTC
docker-io-0.7.0-14.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2013-12-14 02:46:57 UTC
docker-io-0.7.0-14.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.