Bug 1035 - assert fails in telnet when given a very long line.
assert fails in telnet when given a very long line.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: telnet (Show other bugs)
5.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-04 03:12 EST by Aleksey Nogin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-07 17:06:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 1999-02-04 03:12:48 EST
When I ran

(echo "something"; cat some_file) | telnet some_host
some_port

I've got (after some time):

telnet: buffer overflow, losing data, sorry
telnet: ring.cc:132: int ringbuf::flush(): Assertion
`((size+head-tail)%size)==count' failed.
Abort (core dumped)

some_file has a line about 400Kb long.
The bug is 100% reproducable
I run RedHat 5.1 + all updates.
Comment 1 Jeff Johnson 1999-04-07 17:06:59 EDT
Fixed (by scrapping th C++ telnet client in favor of the OpenBSD
client) in telnet-0.10-25.

Note You need to log in before you can comment on or make changes to this bug.