Bug 1035057 - Group "Add Language" field should be limited to something sensible
Group "Add Language" field should be limited to something sensible
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
development
Unspecified Unspecified
unspecified Severity low
: ---
: 3.3
Assigned To: Alex Eng
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-26 19:50 EST by Damian Jansen
Modified: 2014-03-20 01:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.3.0-SNAPSHOT (20131223-0915)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 01:47:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (34.20 KB, image/png)
2013-11-26 19:51 EST, Damian Jansen
no flags Details

  None (edit)
Description Damian Jansen 2013-11-26 19:50:18 EST
Description of problem:
The version group settings page allows a large string to be entered for the add language feature. The string is rightfully rejected, but the error message isn't contained by the box

Version-Release number of selected component (if applicable):
dev

How reproducible:
Easy always

Steps to Reproduce:
1. Sign in as admin, go to Groups
2. Select / Create a group
3. Go to the group settings page, select Languages
4. Enter a long string
5. Press Add

Actual results:
The text breaks the boundary of the error box.

Expected results:
Truncated name in error or, preferably, a sensible limit to the number of characters

Additional info:
Comment 1 Damian Jansen 2013-11-26 19:51:17 EST
Created attachment 829554 [details]
Screenshot
Comment 2 Damian Jansen 2013-11-26 20:44:20 EST
Adding "word-wrap: break-word" to the field error element fixes this visually.
Comment 3 Damian Jansen 2013-11-27 17:54:40 EST
This is related to Bug 1035068 in that if the field is limited, then the field in Admin->Manage Languages needs to be similarly limited - else the situation could arise where the intended language could not be specified.

In this case the wrapping would be the more appropriate approach.
Comment 4 Alex Eng 2013-12-19 16:32:08 EST
Pull request: https://github.com/zanata/zanata-server/pull/325
Comment 5 Damian Jansen 2013-12-22 20:16:52 EST
Verified at cd51a1620e283882a8eb26cd862314b48af67617
Comment 6 Sean Flanigan 2014-03-20 01:47:19 EDT
Closing VERIFIED bugs for Zanata server 3.3.2.

Note You need to log in before you can comment on or make changes to this bug.