Bug 103522 - System hangs when stopping pcmcia services for Fritz ISDN Adapter PCMCIA (A1)
System hangs when stopping pcmcia services for Fritz ISDN Adapter PCMCIA (A1)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-01 15:22 EDT by Tom
Modified: 2015-01-04 17:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-26 23:36:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom 2003-09-01 15:22:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
After installation of Redhat 9 I have created a dialup internet connection using
the Internet connection wizard or the Network configuration tool. The device I
use is the Fritz ISDN PCMCIA A1 card on a Compaq Evo N910 laptop. 

I can browse the internet (i.e., I can activate the network connection).
I can hang up the connection afterwards.

However, the computer hangs during shutdown when PCMCIA or ISDN services are
being stopped.

The same happens if you run >>cardctl eject<< on the command line or if you stop
either the PCMCIA or the ISDN service using the Services tool
(redhat-config-services).

It does not matter whether or not you hang up the connection before trying
either of the steps above - in either case the system becomes un-responsive.


Version-Release number of selected component (if applicable):
kernel-2.4.20-18.9 and 2.4.20-19.9 

How reproducible:
Always

Steps to Reproduce:
1. Install Redhat Linux 9 (Lite Edition from the RedHat Magazine)
2. Plugin a Fritz ISDN PCMCIA card (A1)
3. Create a network connection (dialup)
4. Dial up the connection.
OBSERVE: Everything works fine - you can browse the internet.
5.1 Hang up the connection or let it run and shut down the machine 
OBSERVE: System hangs as soon as either ISDN or PCMCIA service is stopped.
5.2 Try to unload the card using cardctl eject or the redhat-config-services tool
OBSERVE: System becomes unresponsive as well.    

Actual Results:  System hangs and becomes unresponsive

Expected Results:  System should not hang but cardmgr should gracefully exit the
service.

Additional info:

I give this high priority because, if you have a ext2 file system this behaviour
will trigger a file system check each time you reboot the laptop - this is not
acceptable.

Note You need to log in before you can comment on or make changes to this bug.