Bug 103524 - GRUB doesn't work with Logitech Wireless keyboard
GRUB doesn't work with Logitech Wireless keyboard
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: grub (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-01 16:24 EDT by Christian Schaller
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-04 01:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Schaller 2003-09-01 16:24:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030530

Description of problem:
I have a Logitech Wireless keyboard (part of the Logitech optical and wireless
mouse and keyboard bundle). When booting the keyboard works fine with the Bios
(like pressing F1 for the bios config). But it does not work under GRUB at all.
It do work again when linux is fully loaded however. I had the same issue with
RH9, and it is still here in Severn.

I used to have an older revision of the keyboard using RH9 which worked, but
when it broke 6 months ago I got the latest revision from Logitech (this new
version has misc. special keys on the top of the F buttons) and that has never
worked for me with GRUB. I did a fresh install of servern to test.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Hook up Logitech wireless keyboard and boot :)
    

Actual Results:  n/a

Expected Results:  n/a

Additional info:

n/a
Comment 1 Bill Nottingham 2003-09-01 19:26:02 EDT
Is this wireless keyboard connected via PS/2 or USB?
Comment 2 Christian Schaller 2003-09-02 10:40:33 EDT
There is a wireless reciever shared by both keyboard and mouse that is connected
by USB
Comment 3 Jeremy Katz 2003-09-02 11:05:13 EDT
Does your BIOS have an option that's labeled something like "legacy USB
support"?  Could you try using it in the other setting?
Comment 4 Christian Schaller 2003-09-04 01:40:07 EDT
Hi jeremy. Ok, tried enabling the legacy USB keyboard support, and GRUB now
works with the keyboard. But considering that everything pre and post GRUB
worked without I would think GRUB should be able to also?
Comment 5 Jeremy Katz 2003-09-04 01:52:19 EDT
The BIOS has special handling that's per machine.  It only works afterwards
because there's a whole USB stack.  Adding a USB stack to a boot loader and
fitting within the constraints there of is...  hard :)   So you have to have
legacy support to use the keyboard in the boot loader.

Note You need to log in before you can comment on or make changes to this bug.