Bug 10354 - If renewal fails then discover mode fails
If renewal fails then discover mode fails
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: pump (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-26 11:14 EST by Olivier Baudron
Modified: 2007-04-18 12:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:33:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch pump 0.8.18-2 to retry DHCP discovery (5.74 KB, patch)
2003-10-08 13:50 EDT, Andrew Esh
no flags Details | Diff

  None (edit)
Description Olivier Baudron 2000-03-26 11:14:55 EST
This report assumes that bug 10348 is fixed. My ISP is still Cybercable
(provides a non-responding server address for renewal). Then, when renewal
fails, pump uses the discover mode. However, the call to pumpDhcpRun
disable the IP adress of eth0 until I kill pump.

~# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 52:54:00:EC:64:77
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:147 errors:0 dropped:0 overruns:0 frame:0
          TX packets:158 errors:0 dropped:0 overruns:0 carrier:0
          collisions:1 txqueuelen:100
          Interrupt:11 Base address:0xb800

The result is that the renewal disconnect my linux box from the Internet.
Comment 1 Erik Troan 2000-08-04 11:10:18 EDT
Will be fixed in pump-0.8
Comment 2 Olivier Baudron 2000-11-25 15:06:28 EST
This bug has not been resolved. You probably made a confusion with bug 10348.
I turned severity high, because, if the network is down for a few minutes while
pump renews the lease then pump dies and leave the eth0 interface in a broken
configuration, which prevent future connections from outside.

In the following example, I removed the ethernet cable a few seconds before the
renewing time and plug it in again a few minutes later. Pump died and ifconfig
shows:

baud:~# ifconfig 
eth0      Link encap:Ethernet  HWaddr 52:54:00:EC:64:77  
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:3449 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3490 errors:15 dropped:0 overruns:0 carrier:30
          collisions:386 txqueuelen:100 
          Interrupt:11 Base address:0xb800 
Comment 3 Olivier Baudron 2000-11-25 19:36:56 EST
I checked the sources. In fact the problem is not a bug, but an odd algorthmic
choice. Pump assumed that if discover fails then it must release the interface.
I think this is _really_ a bad idea, since the network may be downed for a few
minutes when renewing the lease.
I think that in that case it would be better to delay the renewal, and leave the
ethernet interface up with the same IP adress. The delay time may be set to the
previous lease time...
Comment 4 Elliot Lee 2001-07-18 20:17:59 EDT
Apologies for the unresponsiveness of the previous pump package maintainer...

Because it's very very bad to use an IP address that is not assigned either
statically or via DHCP lease, keeping the interface alive with the same IP
address won't work.
Because pump has been replaced by dhcpcd in rawhide, this bug is obsolete in any
case.
Comment 5 Andrew Esh 2003-10-08 13:50:07 EDT
Created attachment 95024 [details]
Patch pump 0.8.18-2 to retry DHCP discovery

This patch includes CVS logs of what was done to each file as a skippable text
section above the diffs. Patch can be applied as is.
Comment 6 Andrew Esh 2003-10-08 13:51:03 EDT
I attached a patch that fixes this. I can't reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.