Bug 103544 - Korean input is wrong.
Korean input is wrong.
Status: CLOSED DUPLICATE of bug 91481
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gtkhtml3 (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-01 23:03 EDT by David Joo
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Joo 2003-09-01 23:03:21 EDT
Description of problem: When Korean is being input, it doesn't show what is
being typed. Also, when it's all typed, the order of characters are different
Also the position of cursor is worng

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Start Evolution
2. Try to write a new email with Korean
3. 
    
Actual results:
When you type "rkskekfk" you won't be able to see the result of "rk" until you
have "sk" being entered. Also after you enter "rkskekfk", (in UTF-8, it will
look something like "나라다가". Also the position of cursor is in the middle
instead of end of the last character.

Expected results:
The above input should look something like "가나다라"

(You should be able to see these Korean output if you have the browser to have
UTF-8)

Additional info:
To test this better way, please set the /etc/sysconfig/i18n to have following entry.
LANG=ko_KR.eucKR
LC_MESSAGES="en_US.UTF-8"

Then ami's menu will be in English.

To show this bug, you need to set ami in specific way.
KBD Type is : 2bul
INPUT OPTION is : Committed by characters

then save it. but do not close it
if you close it, you won't be able to use ami

To toggle between Korean and English, use, shift+space key
Comment 1 Jeremy Katz 2003-09-02 15:19:07 EDT

*** This bug has been marked as a duplicate of 91481 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.