Bug 1035467 - artifacts on icon mouseover on Intel 4400
artifacts on icon mouseover on Intel 4400
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-27 15:47 EST by Havoc Pennington
Modified: 2015-06-29 09:14 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 09:14:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2013-11-27 15:47:21 EST
Description of problem:

When hovering over application icons or notification icons, there are flickering artifacts (often checkerboard-looking) in the highlight effect. The artifacts appear briefly then vanish. Usually black and white but sometimes there's a little color.

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
 intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4400
Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz

Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.21.15-5.fc20.x86_64
gnome-shell-3.10.2.1-1.fc20.x86_64

How reproducible:

Move mouse back and forth between a couple of app icons in the favorites area to prelight/unprelight the icons. Also happens with notification icons.
Comment 1 eTM 2013-12-04 13:43:39 EST
Same here. 

Also affects Intel(R) HD Graphics 5000. 

Maybe a a bug in intel driver haswell specific code?
Comment 2 Ivan Makfinsky 2013-12-10 09:59:15 EST
I am also experiencing the same issue. I will happily provide whatever information necessary to debug this issue.

lspci:
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)

cpuinfo:
Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz

Xorg:
intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4400
Comment 3 Gareth Williams 2013-12-24 09:45:46 EST
Another "me too!" :-)

I'm running on a i5-4200U which apparently has Intel HD Graphics 4400.  The laptop is a HP Pavilion and the distro is Fedora 20.

I've tried kernels 3.11.10, 3.12.5 and 3.13.0 (from rawhide) and they're all the same.  The Intel drivers are 2.21.15-4 and 2.21.15.5 and the X server is 1.14.4.  I'm using the Cinnamon desktop and this happens with both accelerated and non-accelerated sessions.
Comment 4 Pascal Chapperon 2013-12-27 03:53:53 EST
Same here with fedora 19 on i5-4200U intel HD4400.

I also tried kernel 3.13 (rawhide), with xorg-x11-drv-intel-2.21.15-12.fc21 (rawhide) whith no success.

Then I updated mesa packages (rawhide) and this update solved graphical issues.

Actual version of mesa packages :
# rpm -qa | grep mesa
mesa-libwayland-egl-10.0.1-1.20131220.fc21.x86_64
mesa-libGL-10.0.1-1.20131220.fc21.x86_64
mesa-dri-drivers-10.0.1-1.20131220.fc21.x86_64
mesa-libxatracker-10.0.1-1.20131220.fc21.x86_64
mesa-filesystem-10.0.1-1.20131220.fc21.x86_64
mesa-libGLU-9.0.0-4.fc21.x86_64
mesa-libglapi-10.0.1-1.20131220.fc21.x86_64
mesa-libEGL-10.0.1-1.20131220.fc21.x86_64
mesa-libgbm-10.0.1-1.20131220.fc21.x86_64
Comment 5 Gareth Williams 2013-12-27 04:11:46 EST
I can confirm that Pascal's suggestion of updating the mesa packages worked for me too, although it dragged in 29 packages in total including some Xorg drivers.  It seems stable enough too - maybe we should keep an eye on it for a while before opening the Champagne bottles :-)
Comment 6 Pascal Chapperon 2013-12-27 04:23:40 EST
ah! you are too fast :) I just downgraded the fc21 packages and upgraded them one by one. And the culprit is:
mesa-dri-drivers-10.0.1-1.20131220.fc21.x86_64

Strange that it dragged 29 packages on your box: I can upgrade mesa without any other packages (perhaps because I previously updated all the Xorg packages)
Comment 7 Gareth Williams 2013-12-27 10:19:39 EST
I used the sledgehammer to crack a nut approach of 'yum update mesa*', which updated 13 mesa* packages and 16 dependencies (14 xorg-x11-drv-* and 2 xorg-x11-server-*).

Shouldn't all the mesa packages be at the same version? Either all at 9 or all at 10?  I'm no expert, but I thought mixing them will only cause trouble - but I could be wrong.

This has been reliable all day for me, so this could be good news.
Comment 8 Gareth Williams 2013-12-27 10:25:12 EST
I've also noticed that this bug is filed under 'gnome-shell'.  As I'm seeing this issue under Cinammon-Desktop and the fact that this seems to be a mesa bug, should this bug now be changed to 'mesa'?
Comment 9 Pascal Chapperon 2013-12-27 11:59:15 EST
You are right; this bug must reassigned to mesa maintainer (by reporter or assigned maintainer).

The goal is to backport a single commit (or perhaps 2 or 3) from mesa 10 to mesa 9.2.5 (and 9.2.4 for f19) for the driver i915_dri.so

So imho it is not necessary  to upgrade all the mesa packages, as the best thing for f19 or f20 is: no rawhide packages inside. I want ( and I suppose you want) a stable release.

Sometimes I dream of a rolling release of Fedora (rawhide is too unstable for me)
Comment 10 extremoburo 2014-03-04 05:22:21 EST
to inform you that I have the same issue with F19  on a Lenovo S540 , intel i7-4500U CPU @ 1.80GHz and Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09), the problem began after I've updated all the packages after F19 intallation.
Comment 11 Fedora End Of Life 2015-05-29 05:52:12 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 12 Fedora End Of Life 2015-06-29 09:14:12 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.