Bug 1035483 - synclient can't set SoftButtonAreas
synclient can't set SoftButtonAreas
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-27 16:32 EST by Havoc Pennington
Modified: 2014-02-28 14:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-02 23:10:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2013-11-27 16:32:23 EST
Description of problem:

$ synclient SoftButtonAreas="55% 0 0 0 35% 55% 0 0"
Unknown parameter SoftButtonAreas

Version-Release number of selected component (if applicable):

xorg-x11-drv-synaptics-1.7.1-5.fc20.x86_64

Expected results:

This setting can be set in xorg conf but not via synclient.
Unfortunately it's a setting that would be very useful to set without restarting the X server, since it requires some experimentation to get right.
Comment 1 Peter Hutterer 2013-12-02 23:10:25 EST
The synclient options are named differently because of limitations in the synclient implementation.

$> synclient -l | grep ButtonArea
    RightButtonAreaLeft     = 3472
    RightButtonAreaRight    = 0
    RightButtonAreaTop      = 3900
    RightButtonAreaBottom   = 0
    MiddleButtonAreaLeft    = 0
    MiddleButtonAreaRight   = 0
    MiddleButtonAreaTop     = 0
    MiddleButtonAreaBottom  = 0

These options should work fine, let me know if they don't.
Comment 2 Havoc Pennington 2013-12-03 09:13:27 EST
Thanks, though I think a man page note (or maybe even better, an error message about these from synclient itself) would be nice.
Comment 3 Andre Dietisheim 2014-01-22 17:12:52 EST
This seems not to work in FC20 any more (using Lenovo T530 here):

I: Bus=0011 Vendor=0002 Product=000a Version=0000
N: Name="TPPS/2 IBM TrackPoint"
P: Phys=synaptics-pt/serio0/input0
S: Sysfs=/devices/platform/i8042/serio1/serio2/input/input6
U: Uniq=
H: Handlers=mouse1 event15 
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

 ~]$ synclient RightButtonAreaLeft=3472
Property for 'RightButtonAreaLeft' not available. Skipping.
Comment 4 Peter Hutterer 2014-01-22 21:35:24 EST
judging by the images of the T530 I found, the touchpad has physical buttons. the driver only exposes software buttons for clickpads, i.e. touchpads without physical buttons.

fwiw, the TrackPoint is the red round thing between g and h, the synaptics device is on a different event device.
Comment 5 Andre Dietisheim 2014-01-23 03:29:57 EST
ok gotcha, thanks for the informations. 
So the issues with the t530 touchpad configuration in FC20 must have a different cause.
Comment 6 Peter Hutterer 2014-01-23 16:51:43 EST
Andre, please file a separate bug for that then and assign it to me
Comment 7 Andre Dietisheim 2014-01-24 15:56:37 EST
Thanks Peter!
I created https://bugzilla.redhat.com/show_bug.cgi?id=1057786

Note You need to log in before you can comment on or make changes to this bug.