Bug 103567 - sawfish-ui does not work
sawfish-ui does not work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-02 10:44 EDT by Travis Meisenheimer
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-02 21:11:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Travis Meisenheimer 2003-09-02 10:44:54 EDT
Description of problem:
1. sawfish-ui never works b/c of a can't open socket error

Version-Release number of selected component (if applicable):
sawfish-ui (sawfish 1.2-5)

How reproducible:
always

Steps to Reproduce:
1. /usr/bin/sawfish-ui
2.
3.
    
Actual results:
error: can't connect to socket /tmp/.sawfish-<user>/<hostname>:0.0
*** Error: can't connect to sawfish on display, :0.0 note: user and hostname
would be those values and not <user> or <hostname>

Expected results:
the sawfish-ui manager

Additional info:
I want to install additional gnome themes.  In particular, I want to modify
window styles.  Thta's all.
Comment 1 Havoc Pennington 2003-09-02 11:29:08 EDT
sawfish-ui only works if you're running sawfish.
It should have a better error message, but this is 
an upstream issue; we don't do any active development 
on sawfish.
Comment 2 Travis Meisenheimer 2003-09-02 14:58:42 EDT
This has been an issue since Redhat 8, when Bluecurve was introduced.  My
question is if this won't be resolved as it is marked closed then what is the
point in having in the redhat menu > preferences > more preferences > saw fish
window manager > {focus behavior, key bindings,... etc,}.  If these tools won't
work then they are of no use and need to be removed.
Comment 3 Havoc Pennington 2003-09-02 21:11:26 EDT
sawfish-ui does work, but only when sawfish is running. By default 
sawfish is not the window manager.

sawfish is provided on an as-is basis (other than packaging bugs which we 
address) because some people like it. We don't do active development on it
and this will not change.

If you find a Red Hat specific bug in Sawfish caused by us, we will address it.

Note You need to log in before you can comment on or make changes to this bug.