Bug 1035925 - [abrt] radicale-0.8-5.fc20: __init__.py:925:_open:IOError: [Errno 13] Permission denied: '/var/log/radicale/radicale.log'
Summary: [abrt] radicale-0.8-5.fc20: __init__.py:925:_open:IOError: [Errno 13] Permiss...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: radicale
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Juan Orti Alcaine
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a20c98fe40b18133ca1e0e9b91c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-28 21:28 UTC by Raphos
Modified: 2014-07-15 17:49 UTC (History)
4 users (show)

Fixed In Version: radicale-0.8-6.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-14 03:37:48 UTC


Attachments (Terms of Use)
File: backtrace (1.01 KB, text/plain)
2013-11-28 21:29 UTC, Raphos
no flags Details
File: environ (1.42 KB, text/plain)
2013-11-28 21:29 UTC, Raphos
no flags Details

Description Raphos 2013-11-28 21:28:59 UTC
Description of problem:
Try to start application...

Version-Release number of selected component:
radicale-0.8-5.fc20

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/bin/radicale
dso_list:       python-libs-2.7.5-9.fc20.x86_64
executable:     /usr/bin/radicale
kernel:         3.11.9-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
__init__.py:925:_open:IOError: [Errno 13] Permission denied: '/var/log/radicale/radicale.log'

Traceback (most recent call last):
  File "/usr/bin/radicale", line 32, in <module>
    radicale.__main__.run()
  File "/usr/lib/python2.7/site-packages/radicale/__main__.py", line 93, in run
    log.start()
  File "/usr/lib/python2.7/site-packages/radicale/log.py", line 45, in start
    logging.config.fileConfig(filename)
  File "/usr/lib64/python2.7/logging/config.py", line 78, in fileConfig
    handlers = _install_handlers(cp, formatters)
  File "/usr/lib64/python2.7/logging/config.py", line 156, in _install_handlers
    h = klass(*args)
  File "/usr/lib64/python2.7/logging/__init__.py", line 902, in __init__
    StreamHandler.__init__(self, self._open())
  File "/usr/lib64/python2.7/logging/__init__.py", line 925, in _open
    stream = open(self.baseFilename, self.mode)
IOError: [Errno 13] Permission denied: '/var/log/radicale/radicale.log'

Local variables in innermost frame:
self: <logging.FileHandler object at 0x20f46d0>

Comment 1 Raphos 2013-11-28 21:29:06 UTC
Created attachment 830398 [details]
File: backtrace

Comment 2 Raphos 2013-11-28 21:29:09 UTC
Created attachment 830399 [details]
File: environ

Comment 3 Juan Orti Alcaine 2013-11-29 11:46:43 UTC
It works for me. Could you show me the permissions of that dir?

# ls -laZ /var/log/radicale

Comment 4 Raphos 2013-11-29 12:36:20 UTC
# ls -laZ /var/log/radicale
drwxr-x---. radicale radicale system_u:object_r:radicale_log_t:s0 .
drwxr-xr-x. root     root     system_u:object_r:var_log_t:s0   ..

Comment 5 Fedora Update System 2013-12-01 12:42:36 UTC
radicale-0.8-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/radicale-0.8-6.fc20

Comment 6 Fedora Update System 2013-12-01 17:41:16 UTC
Package radicale-0.8-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing radicale-0.8-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22530/radicale-0.8-6.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2013-12-14 03:37:48 UTC
radicale-0.8-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Raphos 2013-12-25 19:33:34 UTC
Problems still persist with :

radicale.noarch                       0.8-6.fc20                @updates-testing
radicale-httpd.noarch                 0.8-6.fc20                @updates-testing
radicale-selinux.noarch               0.8-6.fc20                @updates-testing

Impossible to start the application.

Comment 9 Juan Orti Alcaine 2013-12-27 15:34:58 UTC
Could you give me more information of the problem? 

journalctl -a -u radicale

I suspect it's not related to opening the log file, if that's the case, please, open a different bug report.

Anyway, I have submitted and updated selinux policy, you can test it to see if it fixes your problems:
https://admin.fedoraproject.org/updates/radicale-0.8-7.fc20

Thank you.

Comment 10 Mathieu Dupuy 2014-07-09 12:52:51 UTC
Problem persists. Noticed today, Fedora 20, package radicale 0.8-7.fc20.
Exact same stack trace.

$ sudo  ls -laZ /var/log/radicale
drwxr-x---. radicale radicale system_u:object_r:var_log_t:s0   .
drwxr-xr-x. root     root     system_u:object_r:var_log_t:s0   ..

$ journalctl -a -u radicale
-- Logs begin at thu. 2014-05-01 03:10:02 CEST, end at wed. 2014-07-09 14:46:54 CEST. --

Comment 11 Mathieu Dupuy 2014-07-09 12:55:46 UTC
Why has it been marked as errata ? That not a reporting error, and dhat prevent the bug being re-opened. Another one need to be filled.

Comment 12 Juan Orti Alcaine 2014-07-15 17:49:56 UTC
I cannot reproduce your problem. If it persists, please, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.