Bug 103599 - mailman upgrade doesn't change aliases
mailman upgrade doesn't change aliases
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-02 17:28 EDT by bill parducci
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-06 05:44:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bill parducci 2003-09-02 17:28:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a)
Gecko/20030728 Mozilla Firebird/0.6.1

Description of problem:
using up2date to upgrade mailman from version 2.0x doesn't work properly because
the aliases have changed for version 2.1x.

Version-Release number of selected component (if applicable):
mailman-2.1-8:3

How reproducible:
Always

Steps to Reproduce:
1. on a machine running mailman 2.0x (with a list setup)

2.  up2date -u 
or
2. `rpm -F mailman-2.1-8.rpm`
or
2. `rpm -U mailman-2.1-8.rpm`

3. try to use existing list

Actual Results:  previous lists do not work because, among other things,
'wrapper' is no longer used and /etc/aliases redirects mail to it.

Expected Results:  deprecated commands (e.g. "|/var/mailman/mail/wrapper post
[listname]") are replaced and/or appended (with the additional commands that
seem to be used) in the /etc/aliases file. 

if that is not feasible, then a sample aliases profile should be presented at
the time of upgrade so that the admin is aware that this must be done manually.
(i figured it out by creating a new list and manually comparing to exisiting
/etc/aliases file.)


Additional info:

even after working this through by hand i still was unable to get existing lists
to work and was unable to find any log entries explaining why. wondering if
there are other signficant changes to mailman architecture outside of wrapper
mods? under cursory review (with lists down i didn't have the time to explore in
depth) it appears that maybe the db structure has changed as well (for the
configuration information?)
Comment 1 Florian La Roche 2004-06-06 05:44:43 EDT
We don't provide full update support for this rpm, so manual adaption
must be done for an existing installation.

greetings,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.