Bug 1036032 - with IPv6 link-local address parse err: invalid character "%"
Summary: with IPv6 link-local address parse err: invalid character "%"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: autofs
Version: 6.6
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: JianHong Yin
URL:
Whiteboard:
: 1036033 (view as bug list)
Depends On: 1035977
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-29 08:59 UTC by JianHong Yin
Modified: 2014-10-14 08:14 UTC (History)
1 user (show)

Fixed In Version: autofs-5.0.5-91.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1035977
Environment:
Last Closed: 2014-10-14 08:14:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch - fix ipv6 link local address handling (1.20 KB, patch)
2013-12-03 03:18 UTC, Ian Kent
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1587 normal SHIPPED_LIVE autofs bug fix update 2014-10-14 01:39:54 UTC

Comment 1 JianHong Yin 2013-11-29 09:14:25 UTC
*** Bug 1036033 has been marked as a duplicate of this bug. ***

Comment 5 JianHong Yin 2013-12-03 03:06:48 UTC
[21:45:08 root@ /mnt/tests/CoreOS/autofs/Regression/bz753964]# timeLimitRun 180 ls -l /mnt/${TESTNAME}/scratchv6
ls: cannot access /mnt/bz753964/scratchv6: No such file or directory
--------------------------------------------------------------------------------

[21:45:08 root@ /mnt/tests/CoreOS/autofs/Regression/bz753964]# cat /var/log/messages | grep "automount\[[0-9]\+\].* calling mount "
:: [   FAIL   ] :: Running 'cat /var/log/messages | grep "automount\[[0-9]\+\].* calling mount "' (Expected 0, got 1)
--------------------------------------------------------------------------------

[21:45:08 root@ /mnt/tests/CoreOS/autofs/Regression/bz753964]# cat /var/log/messages
Dec  2 21:45:08 tyan-gt24-12 automount[8122]: handle_packet: type = 3
Dec  2 21:45:08 tyan-gt24-12 automount[8122]: handle_packet_missing_indirect: token 2, name scratchv6, request pid 8309
Dec  2 21:45:08 tyan-gt24-12 automount[8122]: attempting to mount entry /mnt/bz753964/scratchv6
Dec  2 21:45:08 tyan-gt24-12 automount[8122]: lookup_mount: lookup(file): looking up scratchv6
Dec  2 21:45:08 tyan-gt24-12 automount[8122]: lookup_mount: lookup(file): scratchv6 -> -fstype=nfs4 [2620:52:0:1040:221:5eff:fef0:7d4%eth0]:/exports/home
Dec  2 21:45:08 tyan-gt24-12 automount[8122]: parse_mount: parse(sun): expanded entry: -fstype=nfs4 [2620:52:0:1040:221:5eff:fef0:7d4%eth0]:/exports/home
Dec  2 21:45:08 tyan-gt24-12 automount[8122]: parse_mount: parse(sun): gathered options: fstype=nfs4
Dec  2 21:45:08 tyan-gt24-12 automount[8122]: validate_location: invalid character "%" found in location [2620:52:0:1040:221:5eff:fef0:7d4%eth0]:/exports/home
Dec  2 21:45:08 tyan-gt24-12 automount[8122]: dev_ioctl_send_fail: token = 2
Dec  2 21:45:08 tyan-gt24-12 automount[8122]: failed to mount /mnt/bz753964/scratchv6
--------------------------------------------------------------------------------

Comment 6 Ian Kent 2013-12-03 03:18:37 UTC
Created attachment 831874 [details]
Patch - fix ipv6 link local address handling

I don't see the problem with the patch.
Revision 37 certainly should complain about the % cahracter
with this patch.

Comment 8 Ian Kent 2013-12-03 03:23:48 UTC
(In reply to Ian Kent from comment #6)
> Created attachment 831874 [details]
> Patch - fix ipv6 link local address handling
> 
> I don't see the problem with the patch.
> Revision 37 certainly should complain about the % cahracter
> with this patch.

That should of course be "should not complain" about the %
character.

Comment 19 JianHong Yin 2014-08-20 04:20:06 UTC
Verified:

[23:54:50 root@ ~~]# timeLimitRun 180 ls -l /mnt/${TESTNAME}/scratchv6l
total 0
--------------------------------------------------------------------------------
[23:54:51 root@ ~~]# cat /var/log/messages | grep "automount\[[0-9]\+\]: *mount_mount: *mount(nfs):"
Aug 19 23:54:50 ibm-p8-kvm-03-guest-07 automount[7058]: mount_mount: mount(nfs): root=/mnt/bz753964 name=scratchv6l what=[fe80::3c67:eff:fe21:5904%eth0]:/exports/home, fstype=nfs4, options=
Aug 19 23:54:50 ibm-p8-kvm-03-guest-07 automount[7058]: mount_mount: mount(nfs): nfs options="", nobind=0, nosymlink=0, ro=0
Aug 19 23:54:50 ibm-p8-kvm-03-guest-07 automount[7058]: mount_mount: mount(nfs): calling mkdir_path /mnt/bz753964/scratchv6l
Aug 19 23:54:50 ibm-p8-kvm-03-guest-07 automount[7058]: mount_mount: mount(nfs): calling mount -t nfs4 [fe80::3c67:eff:fe21:5904%eth0]:/exports/home /mnt/bz753964/scratchv6l
:: [   PASS   ] :: Running 'cat /var/log/messages | grep "automount\[[0-9]\+\]: *mount_mount: *mount(nfs):"' (Expected 0, got 0)

Comment 20 errata-xmlrpc 2014-10-14 08:14:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1587.html


Note You need to log in before you can comment on or make changes to this bug.