This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1036150 - publican deals badly with "\n" in po files for strings corresponding to non-verbatim tags
publican deals badly with "\n" in po files for strings corresponding to non-v...
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: 3.2
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-29 10:01 EST by Raphaël Hertzog
Modified: 2013-12-18 21:46 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 21:46:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch fixing newline handling in translated strings (665 bytes, patch)
2013-11-29 10:01 EST, Raphaël Hertzog
no flags Details | Diff

  None (edit)
Description Raphaël Hertzog 2013-11-29 10:01:12 EST
Created attachment 830694 [details]
Patch fixing newline handling in translated strings

I have a translated string like that:

#. Tag: para
#, no-c-format
msgid "With [...] Thank you!"
msgstr ""
"Nous avons reçu le soutien de 650 personnes pendant la campagne de\n"
"financement initiale, et de plusieurs centaines d'autres pendant la\n"
"campagne de libération.  C'est grâce à vous que ce projet a pu voir le\n"
"jour.  Merci à tous !"

Obviously the translators (or its software) word-wrapped the translation string and added newlines where there were none in the original string. Still this should be perfectly OK because he knows that we're writing XML and that newlines should be treated just like spaces.

Unfortunately, that's not the case, the "\n" end up in the generated documents.

I believe that the attached patch fixes this problem with no bad side-effects.
Comment 2 Raphaël Hertzog 2013-11-29 10:05:28 EST
To be clearer, the attached patch solves the problem for me and I have not yet seen any new problems since I use that patch.
Comment 3 HSS Product Manager 2013-12-16 21:47:35 EST
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 4 Jeff Fearn 2013-12-16 22:01:19 EST
Applied patch. Updated PUG it-IT translation and built HTML output.

To ssh://git.fedorahosted.org/git/publican.git
   252d976..6cc0236  HEAD -> devel

Note You need to log in before you can comment on or make changes to this bug.