Bug 103618 - grep command very slow
grep command very slow
Status: CLOSED DUPLICATE of bug 69900
Product: Red Hat Linux
Classification: Retired
Component: grep (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-03 01:13 EDT by A.Kuroki
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A.Kuroki 2003-09-03 01:13:04 EDT
Description of problem:

grep command very slow 

Version-Release number of selected component (if applicable):

# rpm -q grep
grep-2.5.1-7

How reproducible:


Steps to Reproduce:

1. # env | grep LANG
   LANG=ja_JP.eucJP
2. # time grep License message.log
   real    0m23.397s   <---- SLOW
   user    0m15.760s
   sys     0m7.050s
3. # export LANG=C
   # time grep License radiusd.log
   real    0m0.136s    <---- FAST
   user    0m0.070s
   sys     0m0.070s
    
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2003-09-03 05:07:34 EDT
This grep bug has already been reported upstream.

*** This bug has been marked as a duplicate of 69900 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.