Bug 10363 - Invalid socket causes syslog to spin
Summary: Invalid socket causes syslog to spin
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sysklogd   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 17188 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-26 22:39 UTC by scottyin
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-27 16:54:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description scottyin 2000-03-26 22:39:04 UTC
Using the -a option on syslogd to specify a log socket in a directory that
does not exist will cause syslogd to drive CPU usage to 100% and refuse to
listen to log requests on legit sockets.  This means that if you aren't
logged in as root, you will have to hit the reset button, because su,
sshd, etc. all want to write to syslog before they let you become root.

example:

/sbin/syslogd -m 0 -a /tmp/dir_that_doesnt_exist/log

causes CPU usage to go to 100% and local syslog requests to lock up.

Comment 1 Bill Nottingham 2000-03-27 16:54:59 UTC
Fixed in sysklogd-1.3.31-17.

Comment 2 Bill Nottingham 2000-10-02 22:16:12 UTC
*** Bug 17188 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.