Bug 1036332 - [abrt] ibus-1.5.4-2.fc20: _g_log_abort: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
Summary: [abrt] ibus-1.5.4-2.fc20: _g_log_abort: Process /usr/bin/ibus-daemon was kill...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3062b4618be17a04ffb06ac3913...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-01 04:09 UTC by lea89
Modified: 2015-04-21 23:18 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-07 08:50:52 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (16.04 KB, text/plain)
2013-12-01 04:09 UTC, lea89
no flags Details
File: cgroup (172 bytes, text/plain)
2013-12-01 04:09 UTC, lea89
no flags Details
File: core_backtrace (13.14 KB, text/plain)
2013-12-01 04:09 UTC, lea89
no flags Details
File: dso_list (2.80 KB, text/plain)
2013-12-01 04:09 UTC, lea89
no flags Details
File: environ (961 bytes, text/plain)
2013-12-01 04:09 UTC, lea89
no flags Details
File: limits (1.29 KB, text/plain)
2013-12-01 04:09 UTC, lea89
no flags Details
File: maps (13.65 KB, text/plain)
2013-12-01 04:09 UTC, lea89
no flags Details
File: open_fds (658 bytes, text/plain)
2013-12-01 04:09 UTC, lea89
no flags Details
File: proc_pid_status (931 bytes, text/plain)
2013-12-01 04:09 UTC, lea89
no flags Details
File: var_log_messages (203 bytes, text/plain)
2013-12-01 04:09 UTC, lea89
no flags Details

Description lea89 2013-12-01 04:09:05 UTC
Version-Release number of selected component:
ibus-1.5.4-2.fc20

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon --replace --xim --panel disable
crash_function: _g_log_abort
executable:     /usr/bin/ibus-daemon
kernel:         3.11.9-300.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (9 frames)
 #2 _g_log_abort at gmessages.c:255
 #5 bus_dbus_impl_dispatch_message_by_rule at dbusimpl.c:1901
 #6 bus_dbus_impl_connection_filter_cb at dbusimpl.c:1578
 #7 on_worker_message_about_to_be_sent at gdbusconnection.c:2426
 #8 _g_dbus_worker_emit_message_about_to_be_sent at gdbusprivate.c:502
 #9 continue_writing at gdbusprivate.c:1496
 #10 continue_writing_in_idle_cb at gdbusprivate.c:1557
 #15 gdbus_shared_thread_func at gdbusprivate.c:278
 #16 g_thread_proxy at gthread.c:798

Comment 1 lea89 2013-12-01 04:09:13 UTC
Created attachment 831085 [details]
File: backtrace

Comment 2 lea89 2013-12-01 04:09:16 UTC
Created attachment 831086 [details]
File: cgroup

Comment 3 lea89 2013-12-01 04:09:20 UTC
Created attachment 831087 [details]
File: core_backtrace

Comment 4 lea89 2013-12-01 04:09:23 UTC
Created attachment 831088 [details]
File: dso_list

Comment 5 lea89 2013-12-01 04:09:26 UTC
Created attachment 831089 [details]
File: environ

Comment 6 lea89 2013-12-01 04:09:29 UTC
Created attachment 831090 [details]
File: limits

Comment 7 lea89 2013-12-01 04:09:33 UTC
Created attachment 831091 [details]
File: maps

Comment 8 lea89 2013-12-01 04:09:36 UTC
Created attachment 831092 [details]
File: open_fds

Comment 9 lea89 2013-12-01 04:09:40 UTC
Created attachment 831093 [details]
File: proc_pid_status

Comment 10 lea89 2013-12-01 04:09:43 UTC
Created attachment 831094 [details]
File: var_log_messages

Comment 11 fujiwara 2013-12-03 08:49:30 UTC
I cannot reproduce your backtrace.
Are you still able to reproduce your backtrace?

(In reply to lea89 from comment #1)
> Created attachment 831085 [details]
> File: backtrace

> #0  0x00007fea3be21c59 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
> #1  0x00007fea3be23368 in __GI_abort () at abort.c:89
> #2  0x00007fea3c4180ed in _g_log_abort () at gmessages.c:255
> #3  0x00007fea3c435c97 in g_assertion_message (domain=domain@entry=0x4192b3 "IBUS", file=file@entry=0x419786 "dbusimpl.c", line=line@entry=1901, func=func@entry=0x419ce0 <__func__.24736> "bus_dbus_impl_dispatch_message_by_rule", message=message@entry=0x7fea2c006c00 "assertion failed: (skip_connection == NULL || BUS_IS_CONNECTION (skip_connection))") at gtestutils.c:2278
> #4  0x00007fea3c435cfa in g_assertion_message_expr (domain=domain@entry=0x4192b3 "IBUS", file=file@entry=0x419786 "dbusimpl.c", line=line@entry=1901, func=func@entry=0x419ce0 <__func__.24736> "bus_dbus_impl_dispatch_message_by_rule", expr=expr@entry=0x419b60 "skip_connection == NULL || BUS_IS_CONNECTION (skip_connection)") at gtestutils.c:2293
> #5  0x0000000000409be1 in bus_dbus_impl_dispatch_message_by_rule (dbus=dbus@entry=0x1597030, message=message@entry=0x7fea2c010c00, skip_connection=skip_connection@entry=0x162b990) at dbusimpl.c:1901
> #6  0x000000000040a067 in bus_dbus_impl_connection_filter_cb (dbus_connection=<optimized out>, message=0x7fea2c010c00, incoming=<optimized out>, user_data=0x1597030) at dbusimpl.c:1578
> #7  0x00007fea3ca0131f in on_worker_message_about_to_be_sent (worker=<optimized out>, message=0x7fea2c010940, user_data=0x15ba800) at gdbusconnection.c:2426

Comment 12 Mark Tinberg 2013-12-05 05:08:39 UTC
Happened around the time I closed Scribus

reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon --replace --xim --panel disable
crash_function: _g_log_abort
executable:     /usr/bin/ibus-daemon
kernel:         3.11.9-300.fc20.i686+PAE
package:        ibus-1.5.4-2.fc20
reason:         Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 fujiwara 2014-03-07 08:50:52 UTC
If you still see the same backtrace, please comment here.

Comment 14 lea89 2014-09-01 13:45:47 UTC
Apologies. I can not reproduce the problem. I am in Fedora 21.

Comment 15 lea89 2014-09-01 13:46:46 UTC
(In reply to fujiwara from comment #13)
> If you still see the same backtrace, please comment here.

Apologies. I can not reproduce the problem. I am in Fedora 21.

Comment 16 Syam 2014-10-31 13:27:29 UTC
iBus crashed for me today and abrt took me to this report (said it found a duplicate).

FWIW, I'm on Fedora 20, x86_64. Don't remember what I did when iBus crashed. Certainly not typing anything using any input method. I was on KDE and perhaps I closed Firefox and then iBus crashed. But not very sure about this.

Apologies for being so clueless.

Comment 17 kitmaxter 2015-04-21 23:18:57 UTC
I just had the same crash after I ended Skype conversation and immediately quit Skype.

I'm on Fedora 20 x86_64, using KDE.


Note You need to log in before you can comment on or make changes to this bug.