Bug 1036365 - Engine does not verify that proxy supports PM agent
Summary: Engine does not verify that proxy supports PM agent
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Eli Mesika
QA Contact: Tareq Alayan
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-01 14:51 UTC by Eli Mesika
Modified: 2016-02-10 19:36 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 22423 None None None Never

Description Eli Mesika 2013-12-01 14:51:34 UTC
Description of problem:

Engine does not verify that proxy supports PM agent
The fence-agents package of the proxy host may no support the requested power management agent. in this case the whole fencing operation will fail

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Have 3 hosts 
   H1 with 3.1 cluster level in UP on Cluster C1
   H2 with 3.2 or 3.3 in UP on Cluster C2
   H3 with 3.2 or 3.3 in Maintainanace on Cluster C3
2. Configure apc_snmp agent on H2
3. Try to restart H2 from the power management menu
4. A proxy from C1 is selected since there is no other Host in C2 and in teh DC H1 is UP
5. The fencing operation will fail since H1 fence-agants does not support the fence_apc_snmp agent

Actual results:

Fencing operation failed altough H3 can be used as a proxy

Expected results:

Proxy selection should check that the target proxy has support for the requred PM agent 

Additional info:

Comment 1 Sandro Bonazzola 2014-01-14 08:42:46 UTC
ovirt 3.4.0 alpha has been released

Comment 2 Tareq Alayan 2014-02-25 12:04:12 UTC
ok on ovirt-engine-3.4.0-0.11.beta3.el6.noarch

Comment 3 Itamar Heim 2014-06-12 14:08:35 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.