Bug 1036422 - collectd-dbi collectd-memcache package patch
Summary: collectd-dbi collectd-memcache package patch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: collectd
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ruben Kerkhof
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-01 23:14 UTC by Piotr Popieluch
Modified: 2013-12-31 19:02 UTC (History)
4 users (show)

Fixed In Version: collectd-5.3.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-31 19:01:39 UTC


Attachments (Terms of Use)
patch for fc19 spec file (3.21 KB, patch)
2013-12-01 23:14 UTC, Piotr Popieluch
no flags Details | Diff
-lpthread configure file patch for collectd-memcachec (358 bytes, patch)
2013-12-01 23:15 UTC, Piotr Popieluch
no flags Details | Diff
patch for el6 spec file (3.31 KB, patch)
2013-12-01 23:16 UTC, Piotr Popieluch
no flags Details | Diff

Description Piotr Popieluch 2013-12-01 23:14:36 UTC
Created attachment 831323 [details]
patch for fc19 spec file

Description of problem:
collectd-dbi and collectd-memcachec plugins are not included in the default collectd package. I've modified the collectd.spec files for epel el6 and fc19 so that the modules are built as extra packages. Please review my patches.

I've had some issues compiling memcachec on fc19, fixed it by adding a patch on the configure file, notified upstream here: https://github.com/collectd/collectd/issues/494 . The patch adds -lpthread flag to the memcached library ldflags.


Version-Release number of selected component (if applicable):
fc19 and el6, 

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Piotr Popieluch 2013-12-01 23:15:43 UTC
Created attachment 831324 [details]
-lpthread configure file patch for collectd-memcachec

Comment 2 Piotr Popieluch 2013-12-01 23:16:24 UTC
Created attachment 831325 [details]
patch for el6 spec file

Comment 3 Richard W.M. Jones 2013-12-02 08:49:46 UTC
Fedora Rawhide appears to contain the DBI & memcached plugins
already.

Comment 4 Ruben Kerkhof 2013-12-02 09:20:32 UTC
Next to the memcached plugin, collectd also has a memcachec plugin. Confusing, I know. The memcachec plugin indeed fails to build. Adding -lpthread does fix it, but isn't this a bug in memcachec itself?

BTW I have no plans pushing the changes in Rawhide back to F-19 and EL-6.

Comment 5 Piotr Popieluch 2013-12-02 11:11:34 UTC
I didn't notice that they were already added to Rawhide... Is there a way to get the suggested plugins (dbi and memcachec, or more) pushed to el6? If there is anything I can do please let me know.

I think the -lpthread bug is in collectd-memcachec, thats why I submitted the issue on the collectd github issue tracker: https://github.com/collectd/collectd/issues/494 . This bug only occurs at f-19, el6 compiles fine.

Comment 6 Ruben Kerkhof 2013-12-02 16:21:27 UTC
There is no memcachec plugin in F-19, F-20 and Rawhide because of the pthread issue. I'm no expert on these things, but I believe it shouldn't be necessary for collectd to link to libmemcached with -lpthread. The plugin used to work fine in F-18, but I think an update to libmemcached broke this.

Btw, I believe you should use -pthread instead of -lpthread.

I'll look into enabling the dbi plugin in EL-6. Next time, please open 2 separate bugs because these are really two separate issues.

Comment 7 Ruben Kerkhof 2013-12-03 15:35:08 UTC
I was wrong, this is neither a bug in collectd or libmemcached.
It took me a while to find this, and I've gotten a few grey hairs, but it is caused by a bug in libtool #661333

libmemcached correctly uses -pthread to link, but due to the libtool issue this has no effect. Adding -lpthread as a workaround does.

So, first we have to wait for libtool to be fixed, then libmemcached has to be rebuilt, and then I can enable the memcachec plugin in collectd.

Comment 8 Fedora Update System 2013-12-23 10:42:36 UTC
collectd-5.3.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/collectd-5.3.1-1.fc20

Comment 9 Fedora Update System 2013-12-23 12:03:55 UTC
collectd-5.3.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/collectd-5.3.1-1.fc19

Comment 10 Fedora Update System 2013-12-24 03:40:57 UTC
Package collectd-5.3.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing collectd-5.3.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23912/collectd-5.3.1-1.fc19
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2013-12-31 19:01:39 UTC
collectd-5.3.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-12-31 19:02:01 UTC
collectd-5.3.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.