Bug 103643 - shadow-utils-4.0.3-6 on Red Hat 9 ignores upper case
shadow-utils-4.0.3-6 on Red Hat 9 ignores upper case
Status: CLOSED DUPLICATE of bug 89677
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-09-03 10:26 EDT by Eddie Quinteros
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:58:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eddie Quinteros 2003-09-03 10:26:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (WinNT; U)

Description of problem:
The only available shadow-utils rpm for Red Hat 9.0 is shadow-utils-4.0.3-6. It seems that this rpm ignores users whose 
usernames are in upper case.
The following releases:
7.2 = shadow-utils-20000902-9.7
7.3 = shadow-utils-20000902-9.7
8.0 = shadow-utils-20000902-12.8

have the following code in the file libmisc/chkname.c

good_name(const char *name)
         * User/group names must start with a letter, and may not
         * contain colons, commas, newlines (used in passwd/group
         * files...) or any non-printable characters.
        if (!*name || !isalpha(*name))
                return 0;

While the shadow-utils-4.0.3-6 has

good_name(const char *name)
         * User/group names must match [a-z_][a-z0-9_-]*
        if (!*name || !((*name >= 'a' && *name <= 'z') || *name == '_'))
                return 0;

Thus this rpm ignores characters from A-Z. This issue is casing problem in utilities such as useradd

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Additional info
Comment 1 Milan Kerslager 2003-10-23 00:43:21 EDT

*** This bug has been marked as a duplicate of 89677 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.