Bug 1036492 - [RFE] [OVIRT] [VDSM] Hot Plug CPU - Support dynamic virtual CPU allocation and deallocation
Summary: [RFE] [OVIRT] [VDSM] Hot Plug CPU - Support dynamic virtual CPU allocation an...
Keywords:
Status: CLOSED DUPLICATE of bug 1036764
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Roy Golan
QA Contact: Haim
URL:
Whiteboard: virt
: 1036767 (view as bug list)
Depends On: 533138 562886
Blocks: 790582 806907 833102 962051 990116 1036764 1036767 1036768 1036770 1036777
TreeView+ depends on / blocked
 
Reported: 2013-12-02 06:55 UTC by Roy Golan
Modified: 2014-02-10 12:00 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 833102
: 1036764 1036767 1036768 1036770 (view as bug list)
Environment:
Last Closed: 2013-12-12 08:42:03 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Roy Golan 2013-12-02 06:55:54 UTC
oVirt VDSM should support dynamically add/remove virtual CPUs to/from a guest that has this capability

WIKI: www.ovirt.org/Hot_plug_cpu

libvirt's api is setVcpus which is used for both add/remove. 
The guest is configured from the start with some max number of CPUs, and the initial number, the one which was used up till now set as "current". e.g

n: number of CPUs set to start the VM with
m: maximum number of CPUs a guest can have

old:
<vcpu>n</vcpu>

new:
<vcpu current="n" placement="static">m</vcpu>


new api verb:

setNumberOfCpus <vmId> <numberOfCpus>


A seperate RFE will be open for ovirt-engine

Comment 1 Itamar Heim 2013-12-07 20:40:08 UTC
*** Bug 1036767 has been marked as a duplicate of this bug. ***

Comment 2 Itamar Heim 2013-12-12 08:42:03 UTC

*** This bug has been marked as a duplicate of bug 1036764 ***


Note You need to log in before you can comment on or make changes to this bug.