Bug 1036567 - why ExclusiveArch?
why ExclusiveArch?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: springlobby (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gilboa Davara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2013-12-02 04:56 EST by Dan Horák
Modified: 2013-12-22 22:52 EST (History)
1 user (show)

See Also:
Fixed In Version: springlobby-0.169-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-22 22:44:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2013-12-02 04:56:13 EST
springlobby was switched to be x86_64 only, why? Is there a technical reason, is there any bug? Removing primary arch from supported arches requires a bug filled and blocking the ExcludeArch Tracker for ARM (bug 485251).

Please see https://lists.fedoraproject.org/pipermail/devel-announce/2013-August/001224.html and https://fedoraproject.org/wiki/Packaging:Guidelines#Architecture_Build_Failures

BTW the ExclusiveArch tag is incorrect, result to only x86_64 being built, it should be set to "%{ix86} x86_64" if you want x86 arches only


Version-Release number of selected component (if applicable):
springlobby-0.169-7.fc20
Comment 1 Gilboa Davara 2013-12-02 08:45:43 EST
It should be %{ix86} x86_64. Thanks.
As for arm, its not officially supported [1] by springrts and its unlikely that it will be officially supported in the foreseeable future.

I'll fix the broken ExclusiveArch ASAP.

- Gilboa
[1] http://springrts.com/wiki/Spring_on_ARM
Comment 2 Gilboa Davara 2013-12-02 08:47:53 EST
Rechecked: The ExclusiveArch is i386 x86_64 which covers the currently supported platforms.
(I had a weird build issues with mock when using %{ix86} and was pressed on time to get it working). Is it %{ix86} vs. "i386 x86_64" considered nice to have or required?

- Gilboa
Comment 3 Dan Horák 2013-12-02 09:19:29 EST
(In reply to Gilboa Davara from comment #2)
> Rechecked: The ExclusiveArch is i386 x86_64 which covers the currently
> supported platforms.
> (I had a weird build issues with mock when using %{ix86} and was pressed on
> time to get it working). Is it %{ix86} vs. "i386 x86_64" considered nice to
> have or required?

having i386 in the list means there is no 32-bit variant built as Fedora builds as i686

Also still I don't see the reason for the ExclusiveArch as the package builds fine on ARM (http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=172161), ppc/ppc64 and s390/s390x and there is no report from non-x86 arch in Fedora stating it doesn't work or it crashes. And when it will appear then the arch team can look on it before Exclude/ExclusiveArch is set. That's how things work in Fedora.
Comment 4 Gilboa Davara 2013-12-04 13:55:14 EST
Dan,

1. I'll issue a fixed build with x86_64 %{ix86}.
2. Builds != Works. Given the fact that spring/arm is considered non-supported-semi-compiles-state and ppc*/s390 are *completely* unsupported by upstream, there's not much I can do if/when bugs are reported. If you're willing to take ownership of spring/arm, I'll be happy to added it to the supported Arch list.

Thanks for the missing arch report.
- Gilboa
Comment 5 Fedora Update System 2013-12-05 07:13:31 EST
springlobby-0.169-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/springlobby-0.169-8.fc19
Comment 6 Fedora Update System 2013-12-05 07:13:49 EST
springlobby-0.169-8.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/springlobby-0.169-8.fc20
Comment 7 Fedora Update System 2013-12-05 07:14:09 EST
springlobby-0.169-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/springlobby-0.169-8.fc18
Comment 8 Fedora Update System 2013-12-05 07:14:14 EST
spring-95.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/spring-95.0-3.fc19
Comment 9 Fedora Update System 2013-12-05 07:14:33 EST
spring-95.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/spring-95.0-3.fc20
Comment 10 Fedora Update System 2013-12-05 07:14:52 EST
spring-95.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/spring-95.0-3.fc18
Comment 11 Fedora Update System 2013-12-05 16:26:45 EST
Package spring-95.0-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spring-95.0-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22807/spring-95.0-3.fc20
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-12-22 22:44:06 EST
spring-95.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-12-22 22:46:54 EST
spring-95.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-12-22 22:48:32 EST
springlobby-0.169-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-12-22 22:50:58 EST
springlobby-0.169-8.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-12-22 22:51:36 EST
spring-95.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-12-22 22:52:47 EST
springlobby-0.169-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.