Bug 103662 - rpmbuild don't use changed descriptions in spec file
rpmbuild don't use changed descriptions in spec file
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-03 12:47 EDT by Peter Bieringer
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-05 09:11:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2003-09-03 12:47:59 EDT
Description of problem:
I use a spec file of a source RPM, do some adjustments and changed the description.

Package would be built, but the new created RPM doesn't contain the changed
description.

This is very strange indead, on RHL 7.3 this works fine.

Version-Release number of selected component (if applicable):
rpm-build-4.2-0.69

How reproducible:
Always

Steps to Reproduce:
1. change given spec file
2. rebuild rpmbuild -bb <changed+renamed-specfile>
3. rpm -qip <newpackage>
    

Actual Results:  Description is not changed

Example:

$ rpm -qp --queryformat "%{description}\n"
/mnt/rpmbuild/RPMS/i386/httpd-2.0.47-4.test.7.i386.rpm
This package contains a powerful, full-featured, efficient, and
freely-available Web server based on work done by the Apache Software
Foundation. It is also the most popular Web server on the Internet.


Changed spec file contains:

%description
Apache is a powerful, full-featured, efficient, and freely-available
Web server. Apache is also the most popular Web server on the
Internet.
 suEXEC settings:
 Binary  : %{_sbindir}/suexec
 Caller  : %{suexec_caller}
 Doc-Root: %{contentdir}
 UID min : %{suexec_uidmin}
 GID min : %{suexec_gidmin}
 umask   : %{suexec_umask}
 safepath: %{suexec_safepath}




Expected Results:  Changed description
Comment 1 Kaj J. Niemi 2003-09-03 19:35:05 EDT
I bet your locale isn't C when running rpm -qpi ? Try the following:

% LANG=C rpm -qp --queryformat "%{description}\n"
/mnt/rpmbuild/RPMS/i386/httpd-2.0.47-4.test.7.i386.rpm

Also, if you're unsure what's ACTUALLY inside httpd-2.0.47-4.test.7.i386.rpm
 you might want "strings" it, the description is almost at the top.
Comment 2 Peter Bieringer 2003-09-04 02:23:37 EDT
Kay, you'r right, but this don't change the strangeness at all...

Default: LANG=en_US do not display my changed description
Extra given LANG=C does display my changed description

I'm very wondering about where in first case the description is coming from,
because this one displayed is no longer contained in spec file and therefore it
shouldn't no longer contained in new built RPM.

What is the magic mechanism here?
Comment 3 Jeff Johnson 2003-09-05 09:11:58 EDT
description/summary/group from lookaside cache in specspo (rpm -q spcspo)
is probable cause, particularly if changing description of RHL package.
Comment 4 Peter Bieringer 2003-09-06 03:59:56 EDT
rpm -e specspo on target system (not the build system) helps instantly, adjusted
description is now displayed.

Interesting feature...can cause much confusion.

Note You need to log in before you can comment on or make changes to this bug.