Bug 1036824 - vinagre/virt-viewer/virt-manager fullscreen toolbar doesn't work with VNC on f20
vinagre/virt-viewer/virt-manager fullscreen toolbar doesn't work with VNC on f20
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk-vnc (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-02 12:12 EST by Satish Balay
Modified: 2014-11-13 13:12 EST (History)
6 users (show)

See Also:
Fixed In Version: gtk-vnc-0.5.3-6.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-13 13:12:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2013-12-02 12:12:05 EST
Description of problem:

I'm unable to get out of fullscreen mode from the VM

Version-Release number of selected component (if applicable):

virt-manager-0.10.0-5.git1ffcc0cc.fc20.noarch

How reproducible:

Always

Steps to Reproduce:
1. start virt-manager
2. select win7 VM to start
3. toggle the VM to full screen
4. Now attempt to toggle back to normal mode.

Actual results:

There is no menu for toggling back visible

Expected results:

Expect to see a full-screen menu option dropdown - when the mouse is at the top/middle of the screen.

Additional info:

This worked fine on F19
Comment 1 Cole Robinson 2013-12-05 17:14:42 EST
Yeah there's definitely some funkyness here, but only with VNC for me. I assume your VM is using VNC but if not please correct me.

Affects virt-viewer and vinagre so likely a gtk-vnc, though I tried running against older gtk-vnc-0.5.2 and still hit the problem. So maybe a gtk update is tickling a gtk-vnc bug, I'm trying to narrow it down now.
Comment 2 Satish Balay 2013-12-05 17:21:29 EST
Yes - I have VNC in my display settings for the VM.
Comment 3 Cole Robinson 2013-12-06 16:10:40 EST
Some more investigating:

reproduces on gnome shell and kde
I can't get it to reproduce in a VM though
reproduces on two physical machines with f20 alpha and f20 beta livecd, though that's after pulling in the virtualization group which will grab latest gtk-vnc in F20, so not entirely alpha/beta packages.

I still suspect its a gtk3 or similar change that's tickling a gtk-vnc issue, but without being able to reproduce it in a VM it will make bisecting a pain in the ass.
Comment 4 Cole Robinson 2013-12-16 09:37:30 EST
Scratch that, I can reproduce in a VM. The toolbar functions correctly while the VM bios output is shown, but once it switches to grub or regular bootup, things break.
Comment 5 Philippe Troin 2014-07-01 03:49:22 EDT
Seeing the same problem here.
Comment 6 Philippe Troin 2014-07-01 04:05:43 EDT
I've recompiled and tested various vinagre versions on F20:
 - 3.8.3 (the F19 version)
 - 3.10.2 (current F20)
 - 3.13.2 (rawhide)

All of them have the bug.
The interesting part is that 3.8.3, when ran on F19, works fine.

This points to something else than vinagre as the culprit.
Maybe gnome-shell or gtk?
Comment 7 Daniel Berrange 2014-10-09 11:11:51 EDT
I've not been able to ever reproduce this bug myself which makes fixing it rather tricky !
Comment 8 Cole Robinson 2014-10-29 12:08:40 EDT
ping danpb, didn't you come up with a patch for this? I don't see it upstream
Comment 9 Daniel Berrange 2014-10-29 12:14:49 EDT
Yes, just pushed the fix upstream now

commit 3bbaa914d9bfafaf5a4d78867a578bddf5fc9134
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Wed Oct 29 16:13:46 2014 +0000

    Enable double buffering on GTK3
Comment 10 Fedora Update System 2014-10-29 15:51:06 EDT
gtk-vnc-0.5.3-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gtk-vnc-0.5.3-6.fc20
Comment 11 Fedora Update System 2014-10-31 21:46:07 EDT
Package gtk-vnc-0.5.3-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtk-vnc-0.5.3-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-14074/gtk-vnc-0.5.3-6.fc20
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2014-11-13 13:12:14 EST
gtk-vnc-0.5.3-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.