Bug 1036831 - ordered dict is required only with python <= 2.6 (i.e., only EPEL-6)
Summary: ordered dict is required only with python <= 2.6 (i.e., only EPEL-6)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hg-git
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1038330 (view as bug list)
Depends On:
Blocks: 1022220
TreeView+ depends on / blocked
 
Reported: 2013-12-02 17:22 UTC by Matěj Cepl
Modified: 2018-04-11 12:31 UTC (History)
3 users (show)

Fixed In Version: hg-git-0.4.0-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-13 05:04:42 UTC


Attachments (Terms of Use)
suggested patch (1.48 KB, patch)
2013-12-02 17:27 UTC, Matěj Cepl
no flags Details | Diff

Description Matěj Cepl 2013-12-02 17:22:41 UTC
Description of problem:
The fix in bug 1028493 is wrong, because it adds an additional dependency to all packages, not only where it is needed. See http://docs.python.org/2.7/whatsnew/2.7.html ... OrderedDict was then added to the standard library.

Version-Release number of selected component (if applicable):
hg-git-0.4.0-3

How reproducible:
100%

Steps to Reproduce:
1.install hg-git
2.
3.

Actual results:
requires python-ordereddict package

Expected results:
it should install without bothering me

Additional info:

Comment 1 Matěj Cepl 2013-12-02 17:27:45 UTC
Created attachment 831700 [details]
suggested patch

Comment 2 Christopher Meng 2013-12-03 09:01:20 UTC
Thanks, I thought there might have something wrong here before...

I adjusted the patch and pushed the changes, please review.

Comment 3 Fedora Update System 2013-12-03 09:17:41 UTC
hg-git-0.4.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/hg-git-0.4.0-4.fc19

Comment 4 Fedora Update System 2013-12-03 09:17:54 UTC
hg-git-0.4.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hg-git-0.4.0-4.fc20

Comment 5 Fedora Update System 2013-12-03 09:18:06 UTC
hg-git-0.4.0-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/hg-git-0.4.0-3.el6

Comment 6 Fedora Update System 2013-12-03 09:18:22 UTC
hg-git-0.4.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hg-git-0.4.0-4.fc18

Comment 7 Matěj Cepl 2013-12-03 14:18:56 UTC
(In reply to Christopher Meng from comment #2)
> Thanks, I thought there might have something wrong here before...
> 
> I adjusted the patch and pushed the changes, please review.

Agreed.

Comment 8 Fedora Update System 2013-12-03 18:21:20 UTC
Package hg-git-0.4.0-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hg-git-0.4.0-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22642/hg-git-0.4.0-4.fc20
then log in and leave karma (feedback).

Comment 9 Christopher Meng 2013-12-05 03:05:31 UTC
*** Bug 1038330 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2013-12-13 05:04:42 UTC
hg-git-0.4.0-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-12-13 05:06:09 UTC
hg-git-0.4.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-12-14 03:07:38 UTC
hg-git-0.4.0-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2013-12-21 18:54:07 UTC
hg-git-0.4.0-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.