Bug 1036853 - Rebase pyOpenSSL to 0.13.1
Summary: Rebase pyOpenSSL to 0.13.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pyOpenSSL
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: beta
: 6.6
Assignee: Tomas Mraz
QA Contact: Hubert Kario
URL:
Whiteboard:
: 848474 (view as bug list)
Depends On:
Blocks: 1153398 1159926
TreeView+ depends on / blocked
 
Reported: 2013-12-02 18:46 UTC by Lon Hohberger
Modified: 2019-10-10 09:12 UTC (History)
7 users (show)

Fixed In Version: pyOpenSSL-0.13.1-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 06:47:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1337 normal SHIPPED_LIVE pyOpenSSL bug fix and enhancement update 2015-07-20 17:52:57 UTC

Description Lon Hohberger 2013-12-02 18:46:18 UTC
Description of problem: OpenStack requires a newer version of pyOpenSSL than is provided in base RHEL, as the version which is shipped, v0.10, is missing several functions which are used.

Version-Release number of selected component (if applicable): pyOpenSSL-0.10-2.el6

How reproducible: 100%

Steps to Reproduce:
1. Try to use SSL with various OpenStack services

Actual results: Tracebacks / inoperability:

[root@localhost certs(keystone_admin)]# glance image-list
/usr/lib/python2.6/site-packages/glanceclient/common/http.py:390: DeprecationWarning: integer argument expected, got float
  struct.pack('LL', self.timeout, 0))
get_extension_count

Expected results: Normal operation.

Additional info: We can work around this by overriding the version shipped in OpenStack itself, but perhaps it would be beneficial for other products or ISV software as well?

Comment 7 Tomas Mraz 2015-02-26 15:13:38 UTC
*** Bug 848474 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2015-07-22 06:47:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1337.html


Note You need to log in before you can comment on or make changes to this bug.