Bug 1036877 - [abrt] libreoffice-core-4.1.3.2-8.fc20: JNI UNO bridge finalize call still active during exit
Summary: [abrt] libreoffice-core-4.1.3.2-8.fc20: JNI UNO bridge finalize call still ac...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephan Bergmann
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:bc712ba569ad5033130ef51befd...
: 1171466 1209049 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-02 19:59 UTC by Gareth Williams
Modified: 2015-04-07 07:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-09 12:22:20 UTC


Attachments (Terms of Use)
File: backtrace (92.70 KB, text/plain)
2013-12-02 19:59 UTC, Gareth Williams
no flags Details
File: cgroup (172 bytes, text/plain)
2013-12-02 19:59 UTC, Gareth Williams
no flags Details
File: core_backtrace (65.43 KB, text/plain)
2013-12-02 19:59 UTC, Gareth Williams
no flags Details
File: dso_list (22.36 KB, text/plain)
2013-12-02 20:00 UTC, Gareth Williams
no flags Details
File: environ (1.90 KB, text/plain)
2013-12-02 20:00 UTC, Gareth Williams
no flags Details
File: limits (1.29 KB, text/plain)
2013-12-02 20:00 UTC, Gareth Williams
no flags Details
File: maps (131.71 KB, text/plain)
2013-12-02 20:00 UTC, Gareth Williams
no flags Details
File: open_fds (201 bytes, text/plain)
2013-12-02 20:00 UTC, Gareth Williams
no flags Details
File: proc_pid_status (941 bytes, text/plain)
2013-12-02 20:00 UTC, Gareth Williams
no flags Details
File: var_log_messages (338 bytes, text/plain)
2013-12-02 20:00 UTC, Gareth Williams
no flags Details

Description Gareth Williams 2013-12-02 19:59:41 UTC
Description of problem:
Was looking through the Macro dialog on Calc.  Exited Calc as I changed my mind and decided to look at awk to modify my CSV file.  A few seconds later, I was informed of this crash.  Sorry, but I can't be any more specific

Version-Release number of selected component:
libreoffice-core-4.1.3.2-8.fc20

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc file:///home/gareth/Vodafone/download_20131020.csv --splash-pipe=5
crash_function: deallocate
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.11.9-300.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 deallocate at /usr/include/c++/4.8.2/ext/new_allocator.h:110
 #8 destroy_buckets at /usr/include/boost/unordered/detail/table.hpp:588
 #9 delete_buckets at /usr/include/boost/unordered/detail/table.hpp:552
 #10 ~table at /usr/include/boost/unordered/detail/table.hpp:509
 #11 ~table_impl at /usr/include/boost/unordered/detail/unique.hpp:170
 #12 ~unordered_map at /usr/include/boost/unordered/unordered_map.hpp:1060
 #13 helpdatafileproxy::Hdf::releaseHashMap at /usr/src/debug/libreoffice-4.1.3.2/xmlhelp/source/cxxhelp/provider/db.cxx:134
 #14 ~Hdf at /usr/src/debug/libreoffice-4.1.3.2/xmlhelp/source/cxxhelp/provider/db.hxx:116
 #15 chelp::Databases::~Databases at /usr/src/debug/libreoffice-4.1.3.2/xmlhelp/source/cxxhelp/provider/databases.cxx:184
 #16 chelp::ContentProvider::~ContentProvider at /usr/src/debug/libreoffice-4.1.3.2/xmlhelp/source/cxxhelp/provider/provider.cxx:71

Comment 1 Gareth Williams 2013-12-02 19:59:50 UTC
Created attachment 831755 [details]
File: backtrace

Comment 2 Gareth Williams 2013-12-02 19:59:54 UTC
Created attachment 831756 [details]
File: cgroup

Comment 3 Gareth Williams 2013-12-02 19:59:58 UTC
Created attachment 831757 [details]
File: core_backtrace

Comment 4 Gareth Williams 2013-12-02 20:00:03 UTC
Created attachment 831758 [details]
File: dso_list

Comment 5 Gareth Williams 2013-12-02 20:00:08 UTC
Created attachment 831759 [details]
File: environ

Comment 6 Gareth Williams 2013-12-02 20:00:13 UTC
Created attachment 831760 [details]
File: limits

Comment 7 Gareth Williams 2013-12-02 20:00:20 UTC
Created attachment 831761 [details]
File: maps

Comment 8 Gareth Williams 2013-12-02 20:00:24 UTC
Created attachment 831762 [details]
File: open_fds

Comment 9 Gareth Williams 2013-12-02 20:00:29 UTC
Created attachment 831763 [details]
File: proc_pid_status

Comment 10 Gareth Williams 2013-12-02 20:00:36 UTC
Created attachment 831764 [details]
File: var_log_messages

Comment 11 Stephan Bergmann 2013-12-03 08:57:28 UTC
While the main thread 14 is already in exit, thread 1 still runs the finalizer of a Java proxy of a UNO object.  uno_Environment supports a dispose function; lets see how to make this terminate cleanly.

Comment 12 Stephan Bergmann 2014-12-08 07:47:46 UTC
*** Bug 1171466 has been marked as a duplicate of this bug. ***

Comment 13 Stephan Bergmann 2014-12-09 12:22:20 UTC
This has now been addressed for upstream LibreOffice 4.5 with <http://cgit.freedesktop.org/libreoffice/core/commit/?id=6ddde10b4006ece33bc358a391a13e108a35f6fa> "rhbz#1036877: Join Java AsynchronousFinalizer thread well before exit," but I consider that fix too delicate and fresh to backport (at least for now), esp. given this issue should occur rarely and not cause real trouble when it does occur.

Comment 14 Stephan Bergmann 2015-04-07 07:23:17 UTC
*** Bug 1209049 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.