Bug 103705 - tg3.o driver in SMP kernel does not enable network interface
Summary: tg3.o driver in SMP kernel does not enable network interface
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: x86_64 Linux
high
medium
Target Milestone: ---
Assignee: Jim Paradis
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-04 01:39 UTC by Calvin Austin
Modified: 2013-08-06 01:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-02 19:26:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console output with SMP without acpi=off (6.20 KB, text/plain)
2003-09-04 18:50 UTC, Calvin Austin
no flags Details
dmidecode output (6.96 KB, text/plain)
2003-09-26 23:22 UTC, Calvin Austin
no flags Details

Description Calvin Austin 2003-09-04 01:39:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1) Gecko/20020827

Description of problem:
In SMP mode the broadcom network cards initialize ok according to dmesg,  but
fail to bring a network up. The same cards work in UP mode. The tg3 module is
successfully loaded

The driver is tg3.o , the source is v1.6, SMP binary is 64240bytes, 
the UP 64384

Version-Release number of selected component (if applicable):
2.4.21-1.1931.2.393.entsmp

How reproducible:
Always

Steps to Reproduce:
1.boot SMP kernel
2.ifconfig -a
3.ping machine
    

Actual Results:  cannot assign ip address through dhcp

Expected Results:  should bring up a card with ifup eth0

Additional info:

Broadcom NetXtreme BCM5704 Gigabit
beta 1 worked
Have needed to add acpi=off to even get SMP beta 2 to boot

Comment 1 Arjan van de Ven 2003-09-04 07:13:11 UTC
this sounds like an irq routing problem; without ACPI you don't get irq's routed
to the tg3 card

Comment 2 Jim Paradis 2003-09-04 15:11:27 UTC
Can you tell me what model system you are using, and describe how the SMP boot
fails (if you can produce and attach a serial console dump that would be ideal!)


Comment 3 Calvin Austin 2003-09-04 18:50:58 UTC
Created attachment 94212 [details]
serial console output with SMP without acpi=off

Comment 4 Jim Paradis 2003-09-10 17:04:19 UTC
Could you try again?  The crucial part of that serial capture (crash location
and beginning of register dump) is garbled.


Comment 5 Matt Wilson 2003-09-26 00:53:32 UTC
any more info on reproducing this?


Comment 6 Calvin Austin 2003-09-26 05:43:20 UTC
In email with Jim I believe I am seeing an SMP bug in the serial console too. 
I have manually typed in the last lines of the console output, the output is
being overwritten by other output lines. I'll see if I can decipher the rest

Code:  Bad RIP value.
 <<0>4>KeCormneplle ptiannicg : ReAtgiteonm/ptFeied ltd/o Bukiffller t/hPaec
ikdaglee  itnasitk!ia
lizInat iidoln:e <ta4>sk. -. no.t. syn.ci.ng
.. .
<this has corrupted the serial output reads>
<0> Kernel panic Attempted to kill the idle task!
<4>Completing Region/Field/Buffer/Package initialization <4> not syncing


Comment 7 Jim Paradis 2003-09-26 18:17:37 UTC
Please run the /usr/sbin/dmidecode and attach the output.  Thanks!


Comment 8 Calvin Austin 2003-09-26 23:22:20 UTC
Created attachment 94771 [details]
dmidecode output

Comment 9 Calvin Austin 2003-09-26 23:30:54 UTC
On deciphering the crash myself I noticed we never get out of acpi
initialization as such, so the tg3 driver could be a red herring in this case.



Comment 10 Jim Paradis 2003-12-02 19:26:51 UTC
Conversations with customer and AMD show that this is happening on a
prototype platform that will not go into production and that we do not
have access to.  We can only support such configurations on a "best
effort" basis.  Since we couldn't resolve the problem I'm changing
this to WONTFIX.

Comment 11 Calvin Austin 2003-12-13 00:20:05 UTC
Good News I've been meaning to post. With a BIOS update and AS 3.0
Final release (this was originally reported on beta) the network card
now works in SMP mode



Note You need to log in before you can comment on or make changes to this bug.