Bug 103707 - Installer freezes while manually configuring partitions
Installer freezes while manually configuring partitions
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-03 22:45 EDT by Stan Bubrouski
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-14 15:38:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stan Bubrouski 2003-09-03 22:45:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0) Opera 7.20  [en]

Description of problem:
I cannot install RH9 on my Dell OptiPlex GX300 system.  I get to the point where 
I am in Disk Druid trying to setup my partion information (before package 
selection) and the installer completely locks up.  I really don't know how to 
make it happen, but its 100% reproducable.

Before I explain further let me give you an idea of how my HD's are currently 
partitioned.

I have 3 HD which look something like this:

/dev/hda (120 GB Maxtor)
  /dev/hda1 - 20 GB FAT32 (Win2k)
  /dev/hda2 - 48.6 GB NTFS
  /dev/hda3 - 48.6 GB NTFS
/dev/hdb (40 GB WD)
  Unallocated
/dev/hdc (40 GB Maxtor)
  /dev/hdc1 - 15.7 MB Unallocated
  /dev/hdc2 - 20 GB NTFS
  /dev/hdc3 - 18.8 GB ext2
  /dev/hdc4 - 290 MB Unallocated

I'm trying to install RH9 on the second disk (hdb), but
when I get into Disk Druid I see it has checked off
/dev/hdc3 as to be formatted as swap since it shows it
as being swap instead od ext2!  After going to properties
for the partition and setting it to leave the partition
unchanged the installer locks-hard.  I can move the mouse
but nothing, including Ctrl-Alt-Del do anything.  I have
to Alt-SysRq-B to reboot.  I have been unable to work
around this problem.

This is a very serious flaw, which is perpetuated by the
fact, I know that if installation were to continue even
though I unselected /dev/hdc3 and checked leave it alone
Disk Druid would still try to format it (I have had this
problem before :-/)

If this is corrected in RawHide, how would this help me?
I need to install from CD, and I don't see how an anaconda
rpm sitting in rawhide is going to solve the problem since
I do not have a linux install anywhere I can use anaconda
tools on to create a new installation CD... so unless there
is another way I don't think I WILL EVER be able to install
RH9...

-sb


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot install off RH9 CD1
2. Choose Custom Configuration
3. Try to modify existing partition settings on 3rd IDE disk
    

Actual Results:  Installer totally locks up.  Plus recognizes a valid ext2 
partition as swap!

Expected Results:  No freeze and I can setup my partions without brainfarts in 
anaconda or kernel.

Additional info:
Comment 1 Michael Fulbright 2003-09-04 11:59:44 EDT
First thing to try is to boot up the installer and when you get to the first
graphical screen, hit CNTL-ALT_F2.

Then type 'parted /dev/hdc' and then hit 'p<ENTER>' and it will print out a
listing of all the partitions on the drive. What does it list /dev/hdc3 as?
Comment 2 Stan Bubrouski 2003-09-04 12:26:58 EDT
I tried parted, if gave me a warning that another program may have generated an 
incorrect partition table and asked me to ignore or exit.  It said it was 
fixable.  It showed the partition incorrectly as linux-swap.  I don't 
understand why its doing this.  partition magic shows it as ext2 with the 
correct hex, so I'd think parted should do the same?  I don't see why this 
whole disc even matters in the first place.  When I choose manual partitioning 
it shouldn't be selecting ANY partitions for me...right?
Comment 3 Stan Bubrouski 2003-09-04 12:31:37 EDT
Can I correct this problem safely in parted?
Comment 4 Stan Bubrouski 2003-09-04 12:35:30 EDT
nm my previous comment, I can't even check the partion in parted it segfaults 
when I try.  Funny how partition magic will even let me explore the partition 
and parted segfaults before it can even touch it...thoughts?
Comment 5 Stan Bubrouski 2003-09-05 12:31:02 EDT
Maybe I'll try SuSE.  At least their installer isn't broken crap.
Comment 6 Stan Bubrouski 2003-09-05 21:48:31 EDT
Sorry that was curt.  Anyways I'm gonna try Severn, so I can see if it is fixed 
there.
Comment 7 Michael Fulbright 2003-09-16 12:42:11 EDT
Did you try Severn? I have seen the problem you have reported a few times in the
last 2 releases, but we've never been able to reproduce the issue here. I
believe it is related to how the partition table was originally partitioned.

What tool(s) were used to create the partition tables originally?

Thanks for the information you have supplied, I would like to try and resolve
this issue.
Comment 8 Stan Bubrouski 2003-09-19 10:55:28 EDT
Same problem on Severn.  And I can't get anything else to verify
there is something wrong with my partition table like parted
thinks there is.  And a little digging shows the partition is
correctly labeled as ext2 so I dunno why parted thinks its swap,
why the installer won't leave it alone, etc... what's the next
debugging step here?
Comment 9 Stan Bubrouski 2003-09-19 10:58:02 EDT
I missed the last part of your comments.  I'm not sure I remember
what tool I made the partitions with anymore.  It was prolly
partition magic back 3 years ago...and I never once had an
issue installing RH7.2 or using 7.2 on that partition, so
I dunno what gives.  The ext2 partition itself was generated
during RH7.2 install.

-sb
Comment 10 Michael Fulbright 2003-10-03 15:28:06 EDT
This sounds like an issue with libparted (part of the parted package)
incorrectly detecting the partition type.

Do you care what is on that partition or can you reformat it?
Comment 11 Stan Bubrouski 2003-10-03 15:39:50 EDT
I  DO NOT  want to reformat that partition.  I want to leave it as is, at least
until I have another partition to move the data to.   Hence the empty 40 gb
drive I'm trying to put RH9 on.  Unplugging the drive is a last resort, because
I don't want to deal with my Dell bios afterwards.

-sb
Comment 12 Michael Fulbright 2003-10-14 15:38:54 EDT
I do not know of any workaround.  It seems whatever tool(s) were used in
creating the filesystems on your disk left a signature that is confusing the
libparted library.  We have not seen this problem in our testing and it is not
clear it is something that is reproducible that we would then be able to
investigate.

Note You need to log in before you can comment on or make changes to this bug.