Bug 103725 - Anaconda-Kickstart: parameter resolution ignored in the option xconfig
Summary: Anaconda-Kickstart: parameter resolution ignored in the option xconfig
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-04 13:05 UTC by Dirk Rydvan
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-25 23:45:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dirk Rydvan 2003-09-04 13:05:10 UTC
Description of problem:

In the keyword xconfig I have add the option 

xconfig resolution=1280x1024 --depth=24 --defaultdesktop=KDE --startxonboot 

an no more. The other parameter schould be autodetect.
But the Option resolution=1280x1024 will be ignored.

After Installation the file /etc/X11/XF86Config shows the entrys

"800x800" "640x480"

And the Xserver starts with 800x600.

If we use the complete parameters

xconfig --card "Matrox Millennium G450" --hsync 31-80 --vsync 56-75 
resolution=1280x1024 --depth=24 --defaultdesktop kde --startxonboot 

it works!!!!

But we have different PC's and want the card and monitor autodetect!

Version-Release number of selected component (if applicable):

Red Hat Linux 9A


How reproducible:


Steps to Reproduce:
1. Compaq EV0 310
2. create an boot-CD from the boot.iso at the first Linux RedHat 9A CD
   create an simply ks.cfg file an a floppy
   add in this file only the parameter for resolution, depth, desktop 
   and startxonboot 
3. install the system over the bootoption "boot: linux ks=floppy"
    
Actual results:

the parameter resolution will be ignored and select in every 
case "800x600" "640x480" (you can see in the /etc/X11/XF86Config)

Expected results:

The card and monitor will be autodetect, but the given resolution, depth,
defaultdesktop will be used.

Additional info: I have do many trails with manny different parameters,
no success!

Comment 1 Jeremy Katz 2003-09-04 15:14:26 UTC
Your monitor probably isn't auto-probing and so we fall back to "safe"
characteristics.  If you look on tty3 (or /tmp/anaconda.log), you'll probably
see something saying that the monitor couldn't be probed and so it's falling back.

Comment 2 Dirk Rydvan 2003-09-04 15:38:19 UTC
Sorry, but we use the Monitor HP L1820.

If I use redhat-config-xfree86 or simply an install without kickstart -
it works fine an the anaconda detect the right one.

Only with the kickstart ks.cfg file we have problems

Why does ist work during the normal anaconda installation (GUI-Mode)
but not with the ks.cfg file?

As workaround I use in the %post section of the ks.cfg:

/usr/bin/redhat-config-xfree86 --set-resolution1280x1024 --set-depth=24 --
reconfig

Note: The --reconfig option is necessary, because without this option - no 
changes will made on /etc/X11/XF86Config.
An other way is, I delete the file /etc/X11/XF86Config an run /usr/bin/redhat-
config-xfree86 --set-resolution1280x1024 --set-depth=24

(The same effect occours with the GUI-Interface, I can not find the reason for 
it - the acces rights vor the configfile are rw-r--r--)

Comment 3 Jeremy Katz 2003-09-25 23:45:20 UTC
This code has been rewritten a bit.  Even still, if your monitor does not get
probed, then you have to provide some specs for it.


Note You need to log in before you can comment on or make changes to this bug.