Bug 103740 - rebuilding ncurses-5.3-8.src.rpm fails
Summary: rebuilding ncurses-5.3-8.src.rpm fails
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ncurses   
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-04 14:25 UTC by Samuli Kärkkäinen
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-13 19:00:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Samuli Kärkkäinen 2003-09-04 14:25:11 UTC
On RHL9 with rpm-4.2-1, rpmbuild --rebuild ncurses-5.3-8.src.rpm fails with

Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/ncurses-root
error: Installed (but unpackaged) file(s) found:
   /usr/share/man/man2/key_defined.3x.20030517.gz
   /usr/share/man/man2/panel.3x.20030517.gz
 
 
RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/share/man/man2/key_defined.3x.20030517.gz
   /usr/share/man/man2/panel.3x.20030517.gz

Comment 1 Eido Inoue 2003-10-13 19:00:05 UTC
using the current official rpm-4.2-0.69 and the rpm used by the Red Hat build farm

Comment 2 Need Real Name 2004-09-13 21:51:54 UTC
I don't believe this is closed. ncruses.spec has the lines

rm -f ${RPM_BUILD_ROOT}%{_datadir}/man/man2/key_defined.3x.20030517.gz
rm -f ${RPM_BUILD_ROOT}%{_datadir}/man/man2/panel.3x.20030517.gz

but at that point there is no gz version of the files, just the
plains. The reason the rm does not fail is because it has -f in it.

The error is also in ncurses-5.3-9.3.src.rpm fails also.

removing the .gz postfix will fix the problem.



Note You need to log in before you can comment on or make changes to this bug.