Bug 103748 - hcid is unable to start /usr/bin/bluepin helper because of config file parser error
hcid is unable to start /usr/bin/bluepin helper because of config file parser...
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: bluez-utils (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-04 11:59 EDT by Leonid Kanter
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version: 2.3-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-05 09:47:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2003-09-04 11:59:42 EDT
Description of problem:

hcid is unable to parse pin_helper line in hcid.conf. As a result, it's unable
to find bluepin program in /usr/bin. Hardcoded path is /bin/bluepin

Version-Release number of selected component (if applicable):

bluez-utils-2.3-11

How reproducible:

always

Steps to Reproduce:
1. install bluez-utils and bluez-libs
2. configure /etc/modules.conf:

# For Bluez Bluetooth stack
alias net-pf-31 bluez
alias bt-proto-0 l2cap
alias bt-proto-2 sco
alias bt-proto-3 rfcomm
alias bt-proto-4 bnep
3. configure /etc/bluetooth/rfcomm.conf for your bluetooth mobile phone
4. start bluetooth service
5. Try to check status of your phone's modem: statserial /dev/ttyUB0
    
Actual results:

from /var/log/messages:
Sep  4 18:38:08 leon hcid[11398]: HCI daemon ver 2.3 started
Sep  4 18:38:08 leon hcid[11398]: syntax error line 26
Sep  4 18:38:08 leon bluetooth: hcid startup succeeded
Sep  4 18:38:08 leon hcid[11398]: Starting security manager 0
Sep  4 18:39:21 leon hcid[11398]: pin_code_request (sba=17:38:1F:96:A0:00,
dba=D3:41:2B:57:60:00)
Sep  4 18:39:21 leon hcid[11407]: Can't exec PIN helper /bin/bluepin. No such
file or directory(2)

line 26 is "pin_helper /usr/bin/bluepin" !

Expected results:

line 26 must be parsed successfully and "bluepin" must be started from /usr/bin

Additional info:

I moved bluepin from /usr/bin to /bin and it works perfectly from there.
Comment 1 David Woodhouse 2003-09-04 17:19:58 EDT
This is caused by the dbus support patch. I think the right thing to do is
revert it and replace it with a small shell script -- just a wrapper around
dbus-send.
Comment 2 David Woodhouse 2003-09-05 09:47:32 EDT
Updated dbus patch applied; no longer breaks the parser.

Note You need to log in before you can comment on or make changes to this bug.