Bug 1037577 - columns in gtk-based-filemanagers in details view are not moveable over the right border
Summary: columns in gtk-based-filemanagers in details view are not moveable over the r...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-03 12:03 UTC by Rolle
Modified: 2015-02-13 15:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-13 13:17:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Rolle 2013-12-03 12:03:29 UTC
Description of problem:
When I use a gtk-based filemanager (nautilus, nemo, pcmanfm)  and show the file-pane in the detailed view, I couldnt move the 3 last columns on the right (description(?), type(?)/size(?), and date(?)) over the right border.
This is annoying when the filemanager-window gets smaller and filenames are longer. So I couldn't see the filenames. My only choice is to make the filemanager window bigger, which isn't not always possible (like in small display resolution).

Version-Release number of selected component (if applicable):
Fedora 20 beta, Gnome 3.10

How reproducible:
always

Steps to Reproduce:
1. open nautilus or nemo or pcmanfm
2. create a directory with a name, that is not to short (but the problem is still there with short names, but here is problem not so acut)
3. resize the width of filemanager window, so that the directoryname is no more in full length displayed.
4. Try to resize the first column with the name.

Actual results:
The first column with the names is only resizable to a smaller width, but not to a wider width.

Expected results:
The first column with the names should resizable to a wider width, even if the columns right of the "name"-column is moving above the right border. This behavior was in ealier filemanagers.


Additional info:

Comment 2 Matthias Clasen 2015-02-13 13:17:17 UTC
works fine here

Comment 3 Rolle 2015-02-13 15:43:32 UTC
In Fedora 21 with Gnome 3.14 it is changed to the desired behaviour. So thank you.


Note You need to log in before you can comment on or make changes to this bug.