Bug 1037767 - Text install : Error in sys.excepthook
Text install : Error in sys.excepthook
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: ARMTracker F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-12-03 14:01 EST by Paul Whalen
Modified: 2013-12-10 01:53 EST (History)
12 users (show)

See Also:
Fixed In Version: anaconda-20.25.14-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 01:53:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Whalen 2013-12-03 14:01:13 EST
Description of problem:
Interactive install of F20-TC4 is terminated after selecting 'Text' install. 

Version-Release number of selected component (if applicable):
anaconda-20.25.13-1.fc20

How reproducible:
Everytime

Steps to Reproduce:
1. Perform a text-based network installation on ARM using QEMU or real hardware
2. Select the 'Text' option. 


Actual results:
Install is terminated with the following traceback:

Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/meh/handler.py", line 161, in <lambda>
    self.handleException(DumpInfo(ExceptionInfo(ty, value, tb), obj))
  File "/usr/lib/python2.7/site-packages/pyanaconda/exception.py", line 97, in handleException
    from gi.repository import Gtk
  File "/usr/lib/python2.7/site-packages/gi/importer.py", line 68, in load_module
    dynamic_module._load()
  File "/usr/lib/python2.7/site-packages/gi/module.py", line 289, in _load
    self._overrides_module = importlib.import_module('gi.overrides.' + self._namespace)
  File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
    __import__(name)
  File "/usr/lib/python2.7/site-packages/gi/overrides/Gtk.py", line 68, in <module>
    class Widget(Gtk.Widget):
  File "/usr/lib/python2.7/site-packages/gi/module.py", line 176, in __getattr__
    interfaces = tuple(interface for interface in get_interfaces_for_object(info)
  File "/usr/lib/python2.7/site-packages/gi/module.py", line 104, in get_interfaces_for_object
    interfaces.append(getattr(module, name))
[terminated]


Expected results:
Interactive text installation. 

Additional info:
Selecting VNC option working as expected.
Comment 1 Adam Williamson 2013-12-03 20:36:10 EST
From IRC earlier today:

<adamw> oh hey so if you folks didn't see yet, new blocker in tc4, according to pwhalen, text install doesn't work: https://bugzilla.redhat.com/show_bug.cgi?id=1037767
<bcl> mkolman already has a fix for it.

so I'll set this to POST.
Comment 2 lnie 2013-12-04 01:36:38 EST
also see this with x86_64(TC4)
Comment 3 David Shea 2013-12-04 10:19:01 EST
The text install not working is a dupe of bug 1037626. That bug doesn't mention the issue of python-meh falling over on Gtk stuff (which probably also already has a bug, but I don't know which), so I don't know how you want to track this particular bug.
Comment 4 Adam Williamson 2013-12-04 12:25:24 EST
Sorry, c#1 applied to 1037626, not this bug. That bug is the bug for text install not working. This covers a further problem when you hit any crash in text install on ARM: the crash reporter crashes. I think we used to have this on x86 too but fixed it...
Comment 5 Mike Ruckman 2013-12-04 12:31:42 EST
Discussed in 2013-12-04 Blocker Review Meeting [1]. Voted an AcceptedBlocker. Reporting failures on ARM violates the alpha criterion: "The installer must be able to report failures to Bugzilla, with appropriate information included." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-12-04/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Failure_reporting
Comment 6 Brian Lane 2013-12-04 15:02:58 EST
Does the fix for bug 1037626 also fix this? Try this updates.img

http://bcl.fedorapeople.org/updates/1037767.img
Comment 7 Vratislav Podzimek 2013-12-04 19:32:08 EST
The general issue can be tested by switching to the tty2 or second tmux window and sending USR1 signal to the anaconda process (first command in the bash history). That should trigger exception handling which should work properly on every architecture.

From the traceback I can see quite a big issue -- it seems like it's no longer possible to import the Gtk module without the X server running which is quite a big regression in the Gtk. Anaconda tries to import and initialize Gtk to find out if it can run the GUI handler or TUI handler. If the import itself fails, there's nothing that can be done on the Anaconda's side.

If the traceback appears, please try to run python session on tty2 or the second tmux window and enter 'from gi.repository import Gtk' in it. If that raises an exception, please reassing this bug to Gtk.
Comment 8 Mathieu Bridon 2013-12-05 03:39:41 EST
I don't think that's a regression in Gtk.

In the old days, you already couldn't import pygtk if you didn't have a running X server, see bug 208608.
Comment 9 Paul Whalen 2013-12-05 11:29:12 EST
(In reply to Brian C. Lane from comment #6)
> Does the fix for bug 1037626 also fix this? Try this updates.img
> 
> http://bcl.fedorapeople.org/updates/1037767.img

Text installs are now working again using the updates.img
Comment 10 Fedora Update System 2013-12-05 11:52:18 EST
anaconda-20.25.14-1.fc20, python-blivet-0.23.8-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-blivet-0.23.8-1.fc20,anaconda-20.25.14-1.fc20
Comment 11 Adam Williamson 2013-12-05 13:50:00 EST
bcl: I'm not sure that was right. This bug appears to be a breakdown inside python-meh. So yes, the update fixes text installs, and so pwhalen didn't see this bug - but that's because he didn't hit a crash. The correct check for whether this bug is fixed is not 'does text install now work?' but 'if you hit a crasher bug in the installer, do you hit this bug when you try to report it?'

IMBW, but that's what I got from the comments.
Comment 12 Fedora Update System 2013-12-05 16:24:56 EST
Package anaconda-20.25.14-1.fc20, python-blivet-0.23.8-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.14-1.fc20 python-blivet-0.23.8-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22800/python-blivet-0.23.8-1.fc20,anaconda-20.25.14-1.fc20
then log in and leave karma (feedback).
Comment 13 Vratislav Podzimek 2013-12-08 16:50:07 EST
(In reply to Mathieu Bridon from comment #8)
> I don't think that's a regression in Gtk.
> 
> In the old days, you already couldn't import pygtk if you didn't have a
> running X server, see bug 208608.
Yeah, but that was terrible behaviour that was fixed some time ago in the Gtk.py GI overrides. If it is now misbehaving again, it is a regression. Also if it appears only on ARM (text mode exception handling should be tested regurarly), it is quite a big deal.
Comment 14 Fedora Update System 2013-12-10 01:53:38 EST
anaconda-20.25.14-1.fc20, python-blivet-0.23.8-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.