Bug 103791 - Deny ip results in RH welcome page
Deny ip results in RH welcome page
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-04 18:56 EDT by Christopher McCrory
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-05 02:08:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher McCrory 2003-09-04 18:56:29 EDT
Description of problem:
"Deny"ing web requests results in RH welcome page


Version-Release number of selected component (if applicable):
[chrismcc@webtest168 tmp]$ rpm -q httpd
httpd-2.0.46-17.ent


How reproducible:

Always


Steps to Reproduce:
1.

Add Deny from line to httpd.conf e.g.

<Directory "/var/www/html">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    Deny from 192.168.0.0/16
</Directory>


2. access page
3.
    
Actual results:

Get: 
This page is used to test the proper operation of the Apache HTTP server after
it has been installed. If you can read this page, it means that the Apache HTTP
server installed at this site is working properly.


Expected results:

Get "Authorization denied, go away"


Additional info:
Comment 1 Matt Wilson 2003-09-04 20:30:04 EDT
sounds like an enhancement request, not a bug.
Comment 2 Christopher McCrory 2003-09-04 20:33:10 EDT
My reasoning:

having a "default page" , good.

having anything show up when it should be denied, bad.


I thought it would be relatively easy to do this "a slightly better way".  The
<Location ... directive takes precidence over any <Directory ... directives.

So there isn't really a "better way" to configure the same thing.  But I think
having the "welcome page" be /var/www/html/index.html is preferable.


My $0.02
Comment 3 Joe Orton 2003-09-05 02:08:25 EDT
Just get rid of it if you don't want it - the new page explains this :)
 
 # echo > /etc/httpd/conf.d/welcome.conf

It is *not* preferable to version /var/www/html/index.html itself, since that
means we'd blow away your own index.html on upgrades etc.

So given the need for a welcome page and the need for not putting in
/var/www/html, this is the best way we could come up with for implementing it. 
If you can come up with a better way, please reopen!

Note You need to log in before you can comment on or make changes to this bug.