Bug 1037919 - RFE: Enable Fedora-supported ECC algorithms
RFE: Enable Fedora-supported ECC algorithms
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mingw-openssl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Erik van Pienbroek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-03 23:40 EST by Michael Cronenworth
Modified: 2014-02-03 21:51 EST (History)
4 users (show)

See Also:
Fixed In Version: mingw-openssl-1.0.1e-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-27 23:43:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2013-12-03 23:40:32 EST
Description of problem: Per bug 319901 some ECC algorithms are now allowed in Fedora. GnuTLS 3.2.7 has been pushed to rawhide, which requires a new Nettle update. The new Nettle update requires ec.h in OpenSSL.

Please push the necessary updates to F19 and higher.
Comment 1 Richard W.M. Jones 2013-12-05 05:39:12 EST
(In reply to Michael Cronenworth from comment #0)
> Description of problem: Per bug 319901 some ECC algorithms are now allowed
> in Fedora. GnuTLS 3.2.7 has been pushed to rawhide, which requires a new
> Nettle update. The new Nettle update requires ec.h in OpenSSL.
> 
> Please push the necessary updates to F19 and higher.

Not sure about F19/F20.  It seems safer to just put this into Rawhide.
Comment 2 Michael Cronenworth 2013-12-05 09:30:00 EST
Spot pushed updates for F18+ and every Fedora user has been running with ECC enabled since October 18th with several weeks to iron out bugs that cropped up. If you are too uncomfortable with it, rawhide would be good enough.
Comment 3 Fedora Update System 2014-01-25 17:38:49 EST
mingw-openssl-1.0.1e-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mingw-openssl-1.0.1e-5.fc19
Comment 4 Fedora Update System 2014-01-25 17:39:59 EST
mingw-openssl-1.0.1e-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mingw-openssl-1.0.1e-5.fc20
Comment 5 Fedora Update System 2014-01-26 06:53:49 EST
Package mingw-openssl-1.0.1e-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mingw-openssl-1.0.1e-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1560/mingw-openssl-1.0.1e-5.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-01-27 23:43:36 EST
mingw-openssl-1.0.1e-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2014-02-03 21:51:53 EST
mingw-openssl-1.0.1e-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.