Bug 1037924 - [rpc.mountd] update rpc.mountd(8) manpage to change -P option as an alias for -p
Summary: [rpc.mountd] update rpc.mountd(8) manpage to change -P option as an alias for -p
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-04 05:27 UTC by JianHong Yin
Modified: 2016-11-04 04:59 UTC (History)
2 users (show)

Fixed In Version: nfs-utils-1.3.0-0.27.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1037926 1037927 (view as bug list)
Environment:
Last Closed: 2016-11-04 04:59:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2383 0 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2016-11-03 13:53:02 UTC

Description JianHong Yin 2013-12-04 05:27:01 UTC
Description of problem:
[rpc.mountd] -P option parse error.
  in man page:
       -P     Ignored (compatibility with unfsd??).
but in fact, if specify the -P, rpc.mountd error and exit.

Version-Release number of selected component (if applicable):
------------------------------------------------
TimeInfo  : 2013-12-03 23:55:49
CaseName  : /CoreOS/nfs-utils/commands/utils/rpc-mountd
$HOSTNAME : dell-pr7610-01.lab.bos.redhat.com
DistroInfo: RedHatEnterpriseWorkstation 7.0 : RHEL-7.0-20131123.0
kernelInfo: Linux dell-pr7610-01.lab.bos.redhat.com 3.10.0-54.el7.x86_64 #1 SMP Thu Nov 21 15:34:15 EST 2013 x86_64 x86_64 x86_64 GNU/Linux
packageInfo
	libnfsidmap-0.25-7.el7.x86_64
	package libsss_idmap is not installed
	nfs-utils-1.2.9-0.3.el7.x86_64
------------------------------------------------

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:

[23:56:08 root@ /mnt/tests/CoreOS/nfs-utils/commands/utils/rpc-mountd]# rpc.mountd -P
Usage: rpc.mountd [-F|--foreground] [-h|--help] [-v|--version] [-d kind|--debug kind]
	[-o num|--descriptors num] [-f exports-file|--exports-file=file]
	[-p|--port port] [-V version|--nfs-version version]
	[-N version|--no-nfs-version version] [-n|--no-tcp]
	[-H ha-callout-prog] [-s|--state-directory-path path]
	[-g|--manage-gids] [-t num|--num-threads=num] [-u|--no-udp]
:: [   FAIL   ] :: Running 'rpc.mountd -P' (Expected 0, got 1)

Expected results:
ignore the option, as desc in man page.

Additional info:
  RHEL6.5 has the same problem

Comment 2 Ludek Smid 2014-06-26 09:05:23 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Comment 3 Ludek Smid 2014-06-26 11:16:34 UTC
The comment above is incorrect. The correct version is bellow.
I'm sorry for any inconvenience.
---------------------------------------------------------------

This request was NOT resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you need
to escalate this bug.

Comment 6 Steve Dickson 2016-03-10 13:39:54 UTC
The man page is incorrect.... -P is an alias for -p

Comment 7 Yongcheng Yang 2016-05-17 05:34:19 UTC
The needed upstream patch:

commit d0f9df9761d5fc63327fcaa0bc4515e739ca6f0e
Author: Yongcheng Yang <yongcheng.yang@gmail.com>
Date:   Wed Mar 16 12:15:32 2016 -0400

    mountd.man: Update to change -P option as an alias for -p

Comment 9 Yongcheng Yang 2016-05-23 09:12:51 UTC
Verified with nfs-utils-1.3.0-0.27.el7
Move to VERIFIED and continue to run the automatic case.

[root@ibm-x3550m4-02 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.27.el7.x86_64
[root@ibm-x3550m4-02 ~]# man rpc.mountd
[root@ibm-x3550m4-02 ~]# man rpc.mountd | col -b | grep -A5 -e '-P'
       -p num  or  -P num  or  --port num
	      Specifies the port number used for RPC listener sockets.	If this option is not specified, rpc.mountd will try to con‐
	      sult /etc/services, if gets port succeed, set the same port for  all  listener  socket,  otherwise  chooses  a  random
	      ephemeral port for each listener socket.

	      This  option can be used to fix the port value of rpc.mountd's listeners when NFS MOUNT requests must traverse a fire‐
[root@ibm-x3550m4-02 ~]#

Comment 11 errata-xmlrpc 2016-11-04 04:59:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html


Note You need to log in before you can comment on or make changes to this bug.