Bug 1037936 - sssd_be crashes occasionally
Summary: sssd_be crashes occasionally
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-04 05:56 UTC by Kaushik Banerjee
Modified: 2020-05-02 17:34 UTC (History)
6 users (show)

Fixed In Version: sssd-1.11.2-13.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 09:23:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
sssd_be crash backtrace (4.97 KB, text/plain)
2013-12-04 05:56 UTC, Kaushik Banerjee
no flags Details
gzipped coredump file (407.19 KB, application/gzip)
2013-12-04 12:16 UTC, Kaushik Banerjee
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github SSSD sssd issues 3215 0 None None None 2020-05-02 17:34:18 UTC

Description Kaushik Banerjee 2013-12-04 05:56:47 UTC
Created attachment 832421 [details]
sssd_be crash backtrace

Description of problem:
sssd_be crashes occasionally

Version-Release number of selected component (if applicable):
sssd-common-1.11.2-10.el7

How reproducible:
The crash was seen a couple of times during the automation executions.

Steps to Reproduce:
1. Out of the couple of times the crash has happened, it was when sssd was starting up just after the "realm join" process.


Actual results:
sssd_be crashed. Attached the crash backtrace.

Expected results:


Additional info:

Comment 2 Lukas Slebodnik 2013-12-04 09:25:34 UTC
I cannot definitely say from backtrace why sssd crashed,
but it crashed on line:
           strcasecmp(state->dns_domain, state->backup_domain)
It looks like backup_domain is valid, but dns_domain is NULL.

Could you also attach coredump?
Is there any interesting error message in domain log file?

Comment 3 Kaushik Banerjee 2013-12-04 11:23:08 UTC
(In reply to Lukas Slebodnik from comment #2)
> Could you also attach coredump?
> Is there any interesting error message in domain log file?
So far we haven't been able to save the coredump or retrieve any logs. Will attach the coredump when we see the same crash again.

Comment 4 Kaushik Banerjee 2013-12-04 12:16:35 UTC
Created attachment 832623 [details]
gzipped coredump file

Comment 5 Lukas Slebodnik 2013-12-04 14:10:19 UTC
As I thought dns_domain is NULL

(gdb) p *state
$2 = {
  ev = 0x7f82be8c4640, 
  resolv_ctx = 0x7f82be8cf2b0, 
  service = 0x7f82be9014d0 "ldap", 
  protocol = 0x7f82be901540 "tcp", 
  primary_domain = 0x7f82be90b350 "Default-First-Site-Name._sites.sssdad2012.com", 
  backup_domain = 0x7f82be900880 "sssdad2012.com", 
  dns_domain = 0x0, 
  primary_servers = 0x0, 
  num_primary_servers = 0, 
  backup_servers = 0x0, 
  num_backup_servers = 0
}

Comment 6 Pavel Březina 2013-12-05 10:25:16 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2173

Comment 7 Jakub Hrozek 2013-12-09 21:21:35 UTC
Pushed upstream:
    master: c7c01428baf8e29a7997cb879cea109d63c4e581
    sssd-1-11: 11193fe01397439b6e64b4f976143d56ced943de

Comment 9 Kaushik Banerjee 2014-01-15 14:36:57 UTC
Verified in version 1.11.2-24.el7

Crash is no longer seen on automation executions the AD Provider suites.

Comment 10 Ludek Smid 2014-06-13 09:23:52 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.