Bug 1038082 - xorg-x11-server 1.13.0-11.1.el6_4.2 freezes up intermittently (happens usually using mozilla firefox)
Summary: xorg-x11-server 1.13.0-11.1.el6_4.2 freezes up intermittently (happens usuall...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 994246 1056244
TreeView+ depends on / blocked
 
Reported: 2013-12-04 11:31 UTC by Bigyan Shrestha
Modified: 2019-03-22 07:09 UTC (History)
5 users (show)

Fixed In Version: xorg-x11-glamor-0.6.0-5.20140506gitf78901e.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:52:46 UTC


Attachments (Terms of Use)
xorg log file (46.78 KB, text/plain)
2013-12-04 11:32 UTC, Bigyan Shrestha
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1376 normal SHIPPED_LIVE xcb-util, xorg-x11-drivers, and mesa bug fix and enhancement update 2014-10-14 01:11:03 UTC

Description Bigyan Shrestha 2013-12-04 11:31:09 UTC
Description of problem:
On recent update to RHEL 6.5 x86_64 workstation
xorg-x11-server 1.13.0-11.1.el6_4.2 freezes up intermittently.
I am using display driver for nvidia.


Version-Release number of selected component (if applicable):


How reproducible: Intermittent


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: Should not freeze


Additional info:

Comment 1 Bigyan Shrestha 2013-12-04 11:32:08 UTC
Created attachment 832584 [details]
xorg log file

Comment 2 Matthew Gyurgyik 2013-12-13 18:37:01 UTC
I have three desktops that have been experiencing the same problem. My users state that this primarily happens when they are using the scroll bar in firefox. Though they have seen the same behaviour when using the mouse to move between windows.

machine-a$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

machine-b$  lspci | grep -i vga
01:00.0 VGA compatible controller: NVIDIA Corporation GF108GL [Quadro 600] (rev 

machine-c$ lspci | grep -i vga
01:00.0 VGA compatible controller: NVIDIA Corporation GF108GL [Quadro 600] (rev a1)

All machines are fully up-to-date as of 12/12/2013.

$ rpm -qa | grep -i xorg-x11 | grep -v drv
xorg-x11-fonts-misc-7.2-9.1.el6.noarch
xorg-x11-xdm-1.1.6-14.1.el6.x86_64
xorg-x11-fonts-Type1-7.2-9.1.el6.noarch
xorg-x11-xinit-1.0.9-14.el6.x86_64
xorg-x11-server-Xorg-1.13.0-23.el6.x86_64
xorg-x11-fonts-ISO8859-1-100dpi-7.2-9.1.el6.noarch
xorg-x11-utils-7.5-6.el6.x86_64
xorg-x11-server-utils-7.5-13.el6.x86_64
xorg-x11-xauth-1.0.2-7.1.el6.x86_64
xorg-x11-font-utils-7.2-11.el6.x86_64
xorg-x11-proto-devel-7.6-25.el6.noarch
xorg-x11-xkb-utils-7.7-4.el6.x86_64
xorg-x11-fonts-100dpi-7.2-9.1.el6.noarch
xorg-x11-server-common-1.13.0-23.el6.x86_64
xorg-x11-drivers-7.3-13.4.el6.x86_64
xorg-x11-apps-7.6-6.el6.x86_64
xorg-x11-glamor-0.5.0-6.20130401git81aadb8.el6.x86_64

When X freezes, I can SSH into the system, and the system is fully responsive. I have gone through the logs, but have not seen anything obvious. RAM and CPU usage are both low.

When I kill Firefox the display is not updated. I killed all the user running processes (gnome, Firefox, etc..) and the display still showed a full desktop environment (still frozen). Switching to a different tty (Ctrl+Alt+F[1-6]) failed as long of trying to kill X by send Ctrl+Alt+Backspace.

I had my users boot into kernel 2.6.32-358.11.1 and the problem persisted (they are normally running 2.6.32-431). I had one user boot into runlevel 3, log-in to tty1 and issue startx, however the freeze still occurred.

Let me know what information / logs you need from me.

Comment 3 Aron Parsons 2013-12-21 03:50:52 UTC
Try removing the x11-drv-glamor package or removing the config from /usr/share/X11/xorg.conf.d/glamor.conf.

Users of the proprietary NVIDIA driver are hitting the same issue: https://www.mail-archive.com/elrepo@lists.elrepo.org/msg00799.html

Comment 8 errata-xmlrpc 2014-10-14 04:52:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1376.html


Note You need to log in before you can comment on or make changes to this bug.