Bug 1038189 - [fix available] libreoffice does not recognize new printer
Summary: [fix available] libreoffice does not recognize new printer
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-04 15:06 UTC by Subhendu Ghosh
Modified: 2016-10-04 04:31 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-10-14 04:49:54 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1423 normal SHIPPED_LIVE libreoffice bug fix update 2014-10-14 01:28:46 UTC

Description Subhendu Ghosh 2013-12-04 15:06:02 UTC
Description of problem:

Libreoffice does not recognize new printers that are being created on a local print server while the app is running.


Version-Release number of selected component (if applicable):
libreoffice-core-4.0.4.2-9.el6.x86_64


How reproducible:
Always - libreoffice 3.x had the same problem

Steps to Reproduce:
1. Start cups with X printers defined
2. Start libreoffice (tested with writer and calc) and check printer targets that are visible. Should show all X printers from the local print server.
3. While libreoffice is running, add a new printer to the local print server. Local-attach or network printer does not seem to make any difference.


Actual results:
 After step 3. libreoffice print dialog does not show the new printer.

 Restart libreoffice, and the print dialog now shows the new printer.

Expected results:
 After step 3. libreoffice print dioalog should show the new printer.


Additional info:

Comment 1 Caolan McNamara 2013-12-04 15:55:27 UTC
I wonder if visiting "printer settings..." and then cancel it and then visit print if that would refresh it.

Comment 2 Caolan McNamara 2013-12-04 16:56:33 UTC
It looks like that should work as a workaround, i.e. launch the "printer settings" dialog and then revisit print and it should be there.

What I can do safely is to refresh the printer list when the print dialog is launched as well as the printer settings dialog (http://cgit.freedesktop.org/libreoffice/core/commit/?id=02efbed152a3a9e364cdb73628af0aed0f5d6f7a)

Additionally we could do like the gtk print dialog does and continuously poll for new printers every 200ms while its open, but that's a bit riskier and presumably redoing file->print to refresh the list is an acceptable compromise.

Comment 3 Subhendu Ghosh 2013-12-05 18:47:58 UTC
Doing a refresh once when the dialog is invoked is a sufficient compromise.

This solves the issue of libreoffice running all day with different docs, and printer getting added during the day. 

Thanks.

Comment 4 Subhendu Ghosh 2013-12-05 18:50:20 UTC
BTW - removal of printers cause the same issue in reverse - print queues for non-existent printers are shown. 

This should fix that as well.

Comment 5 RHEL Product and Program Management 2014-03-26 00:14:54 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 8 errata-xmlrpc 2014-10-14 04:49:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1423.html


Note You need to log in before you can comment on or make changes to this bug.