Bug 103828 - Gateway Profile 2, with grub kernel doesn't boot all the way, with lilo it works fine
Gateway Profile 2, with grub kernel doesn't boot all the way, with lilo it wo...
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Peter Jones
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-09-05 09:48 EDT by Matthew Lenz
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-01-27 14:16:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew Lenz 2003-09-05 09:48:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
System: Gateway Profile 2, Intel BP810 MB, 64MB memory, 6.8GB Quantum CX  Drive.

I installed from redhat 9 iso's and the installation went fine.  Before
partitioning the installer complained about incorrectly reading the partion
table, but that it was usually safe to ignore this warning and continue.  I
partioned my drive into boot, swap, and root partitions and the installation
completed.  Upon booting the system the grub loader came up and I hit enter on
'Redhat Linux' it would get to right after the 'apm' line in the kernel and then

I tried _a_dding various kernel boot params (disabling all the obvious stuff,
apm, etc) with no success (same failure).  I booted up with 'linux rescue' from
the cd.  'Skip'ped system detection and manually mounted the system partition
and chroot'ed it.  Mounted the boot partition, renamed lilo.conf.anaconda to
lilo.conf in etc and ran lilo.  Rebooted system and now the system boots all the
way and my redhat 9 system is up and running.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
See Description.

Actual Results:  See Description.

Expected Results:  System should have booted all the way with grub.

Additional info:

I checked out /proc/ide/*/geometry and it looks like linux sees the correct
physical geomtry.  I don't know if the logical geometry is correct though.  I
just really thought it was weird that the kernel only booted part way.  Normally
its all or nothing or atleast a panic or something.  I enabled that nmi_debug
param (i think thats what its called) but didn't get any feed back.
Comment 1 Jeremy Katz 2003-09-05 12:52:30 EDT
Does adding 'apm=off' help?
Comment 2 Matthew Lenz 2003-09-05 13:26:31 EDT
Assuming all I need to do is type 'a' at the grub menu and add the params to the
existing list of params (ro, and root) then no, it doesn't help.  It doesn't
seem to hang on the 'apm' kernel message it seems to hang right after the 'apm'
kernel message.  I tried a whole bunch of different combinations.  Even if I do
a 'apm=off' it will still show the kernel message right?  Its just strange that
it works with lilo and not grub, that almost seems like a grub issue to me, but
if that was the case you wouldn't think it would beable to boot at all since it
reads the kernel directly from the boot partion (so it must beable to find the
Comment 3 Matthew Lenz 2003-09-14 02:41:52 EDT
By some miracle I encountered this issue with friends system just this evening.
 He didn't have his keyboard hooked up and it locked in the exact same position
during the kernel boot (right after the APM message line).  His was a dell
system P3-9xx MHz (don't know the model number).  The Difference is that I _had_
a keyboard hooked up, BUT its a usb keyboard (the gateway profile boxes don't
support ps2).  It is almost like the kernel/grub didn't like the fact that we
didn't have "hardware"/ps2 mice hooked up when booting.  Hopefully this helps
identify this as a known problem.
Comment 4 Peter Jones 2005-01-27 14:16:56 EST
This sounds like a BIOS fault.  Either way, with no activity in more than a
year, I'm going to close this bug.  If it pops up again with a more current
distro, feel free to open a new bug.

Note You need to log in before you can comment on or make changes to this bug.