Bug 1038403 - [abrt] dnf-0.4.9-1.fc20: base.py:1832:handle_erase:AssertionError
Summary: [abrt] dnf-0.4.9-1.fc20: base.py:1832:handle_erase:AssertionError
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 20
Hardware: x86_64 Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Holy
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:7dbf9008eec05854b7d67cf7ecb...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-05 04:36 UTC by lnie
Modified: 2015-10-06 02:14 UTC (History)
4 users (show)

Fixed In Version: dnf-0.4.10-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-04 19:53:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.45 KB, text/plain)
2013-12-05 04:36 UTC, lnie
no flags Details
File: environ (2.86 KB, text/plain)
2013-12-05 04:37 UTC, lnie
no flags Details

Description lnie 2013-12-05 04:36:44 UTC
Description of problem:
1)install  dnf
2)dnf install  xchat
3)dnf install libvirt
4) dnf history rollback 1
5) dnf history rollback 2

Version-Release number of selected component:
dnf-0.4.9-1.fc20

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/bin/dnf history rollback 2
executable:     /usr/bin/dnf
kernel:         3.11.9-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
base.py:1832:handle_erase:AssertionError

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 260, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 63, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 122, in _main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1471, in run
    return self.command.doCommand(self.base.basecmd, self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 2157, in doCommand
    ret = self._hcmd_rollback(extcmds[1:])
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 2055, in _hcmd_rollback
    return self.base.history_rollback_transaction(extcmd)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1067, in history_rollback_transaction
    self.history_undo_operations(operations)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 1883, in history_undo_operations
    handle_erase(nevra)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 1832, in handle_erase
    assert len(pkgs) == 1
AssertionError

Local variables in innermost frame:
self: <dnf.cli.cli.BaseCli object at 0x13bb750>
old_nevra: u'libvirt-0:1.1.3.1-2.fc20.x86_64'
pkgs: <dnf.query.Query object at 0x14d8780>

Comment 1 lnie 2013-12-05 04:36:57 UTC
Created attachment 832990 [details]
File: backtrace

Comment 2 lnie 2013-12-05 04:37:01 UTC
Created attachment 832991 [details]
File: environ

Comment 3 Ales Kozumplik 2013-12-05 06:39:54 UTC
Radek this looks like a one for you.

Comment 4 Radek Holy 2013-12-16 12:55:25 UTC
Fixed by 27ba088b9e624c4712de6e0adc466169668f24d1 on master.

Comment 5 Fedora Update System 2014-01-02 10:09:58 UTC
dnf-0.4.10-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.10-1.fc20

Comment 6 Fedora Update System 2014-01-03 08:41:44 UTC
Package dnf-0.4.10-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.10-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0089/dnf-0.4.10-1.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-01-04 19:53:18 UTC
dnf-0.4.10-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.