Bug 10385 - xfs won't use freefont and sharefont when added to /etc/X11/fs/config
xfs won't use freefont and sharefont when added to /etc/X11/fs/config
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-28 09:51 EST by Scott Dowdle
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 14:35:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2000-03-28 09:51:13 EST
I didn't see xfs listed as a Component so I was forced to pick XFree86.

After upgrading from RHL6.1 to 6.2 and installing the freefont and
sharefont packages that are popular among us GIMP users... and then adding
a reference to freefont and sharefont to /etc/X11/fs/config... stopped and
started xfs and then started X with the end result of the fonts not being
available.  I also tried another method as documented in the Grokking the
GIMP book
(http://gimp-savvy.com/BOOK/node12.html#SECTION00844000000000000000) of
using:

xset fp+ /usr/X11R6/lib/X11/fonts/freefont
xset fp+ /usr/X11R6/lib/X11/fonts/sharefont
xset fp rehash

...but that didn't work either.  I checked the ownership and permissions on
all files and directories and nothing looked out of ordinary.

I also added the font paths to /etc/X11/XF86Config and that didn't help
either.  Is it me, or is just broken?  Help, I need more fonts!

Any ideas?
Comment 1 Scott Dowdle 2000-03-28 11:00:59 EST
Finally got it working by copying the freefont/fonts.dir and sharefont/fonts.dir
from my working RHL 6.1 system into the appropriate dirs on the 6.2 system and
restarting xfs.  After skimming the man page for xfs and comparing the two fonts
directories from 6.1 and 6.2, I guess the process has changed since 6.1 didn't
have a /usr/X11R6/lib/X11/fonts/encodings directory and 6.2 did.  Attempted to
run the mkfontdir command to generate the fonts.dir file in each directory but
didn't know what I was doing so I did it the lazy way and just copied it from
the other system.  Somewhere the automatic fonts.dir creation whenever a new
font is added is broken.  I'm assuming it was working with 6.1 because I didn't
have to bother with any of this in the past.

Thanks for any consideration on fixing this.  It appears to me to be a
configuration glitch or a policy change but since I don't know the techincal
aspects of all of this, I'm just speculating.  I did run Xconfigurator again
just in case the format/options in /etc/X11/XF86Config had changed with the
upgrade.

Like everyone else, I'm awaiting the XFree86 4.0 packages but don't expect them
anytime soon given the fact that that XFree86 4 seems to conflict with some
shmem changes in the development kernel and a few things are left to be ironed
out with it.
Comment 2 Preston Brown 2000-05-30 14:35:59 EDT
xfs startup script has some fixes; will be released with an X errata this week.
Comment 3 Simon Hill 2000-08-28 22:43:42 EDT
What happened to this errata? It sounds like it will solve the X problem I am
having on RH6.2 on my Alpha!

Note You need to log in before you can comment on or make changes to this bug.