Bug 103869 - Reiserfs not installed on Taroon beta2 for s390
Reiserfs not installed on Taroon beta2 for s390
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: dff
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-05 17:49 EDT by Jim Sibley
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 15:39:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Sibley 2003-09-05 17:49:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

Description of problem:
The reiserfs system is not installed on the taroon beta2 for s390. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. attempt to format new volume reiser
2. attempt to mount existing volume reiser
3.
    

Actual Results:  1.  -bash: mkireiserfs: command not found
2. mount: fs type reiserfs not supported by kernel

Expected Results:  Based on bug reports for Beta1, I expected to be able to use
reiser on beta2.

Additional info:

SuSE 2.4.19 level has been out for almost a year and that is what we have been
using because an equivalent RedHat above 2.4.17 has not been available. SuSE's
preference is reiserfs, hence all our data is under reiserfs. 

Since I have several thousand volumes under reiser, I cannot test any the beta
any further because I cannot access my current data. Converting a few thousand
volumes to ext3 is not practical.

And since this data is already reiser, it is imperative that reiser be available.
Comment 1 Matt Wilson 2003-09-05 18:03:46 EDT
if the data is not needed during install (doubt that it is), install
kernel-unsupported after rebooting into system.  True, mkreiserfs is not here.
Comment 2 Matt Wilson 2003-09-05 18:04:13 EDT
(and mkreiserfs should not prevent you from testing.  Please continue to test)
Comment 3 Jim Sibley 2003-09-05 18:12:20 EDT
Matt, several questions come to mind.

I installed EVERYTHING during the install. Why is kernel-supported not included?

Since kernel-unsupported is not included in EVERYTHING, how can I install it
after the build?

Also, mkreiserfs is part of my test plan because I already have several
thousands volumes already formatted as reiser. I have to test the your
implementation of reiser. If I find ext3 truely superior, then I need a way to
get from my existing reiser to ext3, should I choose.

Comment 4 Jim Sibley 2003-09-05 18:24:06 EDT
I installed kernel-unsupported. Apparently the word "Everyting" has a limited
meaning. ;-)

mount -t reiserfs seems to work

mkreiserfs is still missing as are the other reiser tools. Looking in /sbin,
degugreiserfs, mkfs.reiserfs. reiserfsck, resize_reiserfs, fsck.feiserfs,
mkreiserfs, and reiserfstune are not there. I can find the man pages, but no
utilities.
Comment 5 Matt Wilson 2003-09-05 21:40:41 EDT
Bill, what's your take on the impact of your test plan since reiserfs isn't a
supported component on RHEL 3 and is not required in the deliverable?
Comment 6 Bill Goodrich 2003-09-16 14:50:13 EDT
We don't plan to do anything with this since you don't support it. We have a
line item in our planning data base but don't include that scenario in the Red
Hat test plan. So there is really no impact to us. 

Comment 8 Suzanne Hillman 2003-12-16 15:39:38 EST
As it has been months since comment #6, I'm closing this as WONTFIX.
Comment 9 Jim Sibley 2003-12-16 15:45:28 EST
I've noticed that the reiser utilities are on rh9 for i386. Why aren't
they available for s/390?

Note You need to log in before you can comment on or make changes to this bug.