Bug 1038855 - in rescue mode, when exiting rescue shell, instead of menu, get "Pane is dead"
Summary: in rescue mode, when exiting rescue shell, instead of menu, get "Pane is dead"
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeExcepti...
Depends On:
Blocks: F20FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-12-06 00:11 UTC by Andre Robatino
Modified: 2015-06-30 01:25 UTC (History)
10 users (show)

Fixed In Version: anaconda-21.14-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1042722 (view as bug list)
Environment:
Last Closed: 2015-06-30 01:25:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Andre Robatino 2013-12-06 00:11:34 UTC
Description of problem:
With 20 Final TC4 and TC5, when using rescue mode and exiting rescue shell, instead of the menu, you get "Pane is dead". Other than that, rescue mode still works. This worked normally prior to TC4.

Version-Release number of selected component (if applicable):
anaconda-20.25.13-1 and anaconda-20.25.14-1

How reproducible:
always

Comment 1 Kamil Páral 2013-12-12 14:06:45 UTC
I can reproduce this with F20 RC1. Anaconda tells you that the system will be rebooted after you exit the shell, but if you do, your "pane is dead" and you can't do anything. However, all your partitions are still mounted and if you force-reboot the PC, you might lose some data (you probably used rescue mode to save data, not lose it).

Someone might argue that the inability to restart safely violates:
"The rescue mode of the installer must be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations. "
https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#rescue-mode
because the recovery operations might not work well in this case. Alternatively this might be accepted as a freeze exception if we slip. Proposing for discussion.

The workaround here is to press Ctrl+Alt+Delete or switch to second pane using Ctrl+b 2 (or tty2) and run "reboot" there. Not very obvious. But people performing rescue operations in shell might be usually capable of discovering that. Also, I assume that there needs to be no additional magic done before rebooting.

Comment 2 Kamil Páral 2013-12-12 17:57:42 UTC
Discussed at Go/No-Go meeting on 2013-12-12 [1]. This is a RejectedBlocker and an AcceptedFreezeException. This bug is not considered to block release. A fix will be considered sometime.

[1] http://meetbot.fedoraproject.org/fedora-meeting-2/2013-12-12/

Comment 3 Gene Czarcinski 2013-12-13 08:10:25 UTC
In the "old" rescue mode, even if you selected "skip", you were still presented with a menu to get to the shell prompt or to reboot.  This has been eliminated which is probably no great loss but this "Pane is dead" is going to confuse some folks.

Q: why eliminate that menu?

Comment 4 Arthur Benoit 2014-05-07 20:24:04 UTC
Vratislav,
I ran into what I think is this problem while running a Beaker provision on cisco-e160dp-01.rhts.eng.bos.redhat.com. The job fails with Pane is dead. I've tried both Fedora-20 and Fedora-20-Alpha and both show the problem.

https://beaker.engineering.redhat.com/jobs/647926
https://beaker.engineering.redhat.com/jobs/647762

Thanks,
Arthur

Comment 5 Fedora End Of Life 2015-05-29 09:55:40 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Leslie Satenstein 2015-06-01 20:32:58 UTC
This same problem occurred with Fedora 22 testing.

If the disk scanner to determine partitions and free space has not completed, or is in the early part of it's process, there will be a warning window presented. If the response to this message is before the scan has completed, it will appear with a bright white background, no text, and subsequently, "Pane is dead"

The circumvention, is to wait for the "disk active" LED light to stop flashing. Flashing indicates a disk scan is in process, and if one steps through Anaconda at this time, the "Pane is dead" will must likely occur. 

Perform a validation check that the burning of the flash drive or CD/DVD has been done without error. The extra delay taken to check the Fedora source media will make harmless the "Pane is dead" problem. 

Alternately, wait for the disk activity LED to stop flashing before responding to Anaconda's installation language selection.

Still a Problem with Fedora 22.

Comment 7 Vratislav Podzimek 2015-06-02 07:00:47 UTC
We would like to rewrite the rescue mode from ncurses/newt to our framework for text mode and this should be resolved as part of the rewrite.

Comment 8 Adam Williamson 2015-06-30 00:32:50 UTC
In any case, it's clearly not the same bug, as described.

Comment 9 Fedora End Of Life 2015-06-30 01:25:31 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.